summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2013-01-18 01:37:27 +0000
committerGerald Combs <gerald@wireshark.org>2013-01-18 01:37:27 +0000
commita377c7c38d97f177df237deb04af11a316e3f83f (patch)
treedbea28eb7dc1e54e419de862c507661f4fe13912 /CMakeLists.txt
parent5efca1b8e161f725149eb451b8331f41445b10d6 (diff)
downloadwireshark-a377c7c38d97f177df237deb04af11a316e3f83f.tar.gz
Generate Info.plist using CMake and enable it in QtShark.pro. Update the dates.
svn path=/trunk/; revision=47143
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6810dcbca6..495f0504b2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -543,6 +543,14 @@ endif()
configure_file(${CMAKE_SOURCE_DIR}/cmakeconfig.h.in ${CMAKE_BINARY_DIR}/config.h)
+set( configure_input "Built with ${CMAKE_COMMAND}" )
+set( VERSION ${PROJECT_VERSION} )
+
+configure_file(
+ ${CMAKE_SOURCE_DIR}/packaging/macosx/Info.plist.in
+ ${CMAKE_SOURCE_DIR}/packaging/macosx/Info.plist
+ @ONLY)
+
include(FeatureSummary)
#SET_FEATURE_INFO(NAME DESCRIPTION [URL [COMMENT] ]
#FEATURE_SUMMARY(WHAT ALL) Requires removal of our local copy of FeatureSummary