summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2016-08-03 12:14:23 -0700
committerGerald Combs <gerald@wireshark.org>2017-02-16 16:58:12 +0000
commita5a8fce06ecb5aff1dfcf101bb2b5455bd776569 (patch)
tree2eb0c0578ebd12b49868e817aba900d8824e99a0 /CMakeLists.txt
parent815916b174ce48d65aace9852629f63f45e12704 (diff)
downloadwireshark-a5a8fce06ecb5aff1dfcf101bb2b5455bd776569.tar.gz
Qt: Warn the user about DBAR 1.8 on Windows.
At startup, dig through the registry looking for shell extensions. If any of them match known Dell Backup and Recovery DLL names and the DLL version matches 1.8.*.*, show the user a warning dialog. This is a bit extreme but I'm not sure what else to do. Dell is a popular computer manufacturer and bug reports keep trickling in. Change-Id: I6d1bd6c56850279356570154d231b07facb30cff Bug: 12036 Ping-bug: 12701 Ping-bug: 13414 Reviewed-on: https://code.wireshark.org/review/16861 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com> Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 08eb05c31b..720ee7d502 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1959,6 +1959,7 @@ if(BUILD_wireshark AND QT_FOUND)
${APPLE_CORE_FOUNDATION_LIBRARY}
${APPLE_SYSTEM_CONFIGURATION_LIBRARY}
${NL_LIBRARIES}
+ ${WIN_VERSION_LIBRARY}
)
# Policy since 2.8.11