summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2016-09-26 10:34:04 -0700
committerGerald Combs <gerald@wireshark.org>2016-09-26 23:17:02 +0000
commitb725d6c9acc403dba30c72d20cf7103e4f490334 (patch)
tree90a8b5d226630b8ed14fb9d5a1a50104a254bf6a /CMakeLists.txt
parent06352a27b1ad2f9197b6193f97fad0c6947cc6d6 (diff)
downloadwireshark-b725d6c9acc403dba30c72d20cf7103e4f490334.tar.gz
Add an initial "shellcheck" target.
Look for shellcheck in Autotools and CMake, and if found add a target that checks some of our shell scripts. Add a "source=" directive to targets that include test-common.sh so that shellcheck will correctly process the scripts. Note that this requires shellcheck 0.4.0 or later. To do: Fix the issues that shellcheck found and check more scripts. Change-Id: I441f9f59d8a3f8eec6718119c2370f2560b98f3c Reviewed-on: https://code.wireshark.org/review/17943 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3ff8415106..0530ee359e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2769,6 +2769,25 @@ CHECKAPI(
${TSHARK_TAP_SRC}
)
+find_program(SHELLCHECK_EXECUTABLE shellcheck
+ DOC "Path to the shellcheck utility."
+)
+if (NOT "${SHELLCHECK_EXECUTABLE}" STREQUAL "SHELLCHECK_EXECUTABLE-NOTFOUND")
+ add_custom_target(shellcheck)
+ set_target_properties(shellcheck PROPERTIES FOLDER "Tests")
+ # --external-sources requires 0.4.0 or later.
+ add_custom_command(TARGET shellcheck POST_BUILD
+ COMMAND shellcheck --external-sources
+ tools/fuzz-test.sh
+ tools/randpkt-test.sh
+ tools/runa2x.sh
+ tools/test-captures.sh
+ tools/valgrind-wireshark.sh
+ WORKING_DIRECTORY "${CMAKE_SOURCE_DIR}"
+ )
+endif()
+
+
#
# Editor modelines - http://www.wireshark.org/tools/modelines.html
#