summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Mayer <jmayer@loplof.de>2017-04-13 16:34:49 +0200
committerMichael Mann <mmann78@netscape.net>2017-04-14 11:29:31 +0000
commitbf5fd112bcfdafa9050c1fcd88aaa29cff0f34d4 (patch)
tree4acff10d3558632d4d4501de4325b4ce9d6bff8a /CMakeLists.txt
parent77e67a3e8a2e7bb8ac481f5e01300915de3cde95 (diff)
downloadwireshark-bf5fd112bcfdafa9050c1fcd88aaa29cff0f34d4.tar.gz
Functions that put large amounts of static data onto the stack may be
worth looking at every now and then. The value of 16384 is the same as the default in VS. Change-Id: I68fd51e373437088f59c1e197d1a889f856caded Reviewed-on: https://code.wireshark.org/review/21030 Petri-Dish: Pascal Quantin <pascal.quantin@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bafcd59750..16459bf5cf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -414,6 +414,10 @@ else()
-Wno-overlength-strings
-Wno-long-long
-Wheader-guard
+ #
+ # Code that may be worth looking into (coding practices)
+ #
+ -Wframe-larger-than=16384
)
set(C_WARN_FLAGS