summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2016-10-19 15:54:32 +0200
committerRoland Knall <rknall@gmail.com>2016-10-20 13:06:17 +0000
commitc9fa9b51dea34dc5576c61c14633753b2bcc5768 (patch)
tree2ef10dbe6a20c4ae1b21e3b87f03827802f7f405 /CMakeLists.txt
parent9e42cad18a049ed0a52f337f91be1096887dbca4 (diff)
downloadwireshark-c9fa9b51dea34dc5576c61c14633753b2bcc5768.tar.gz
cmake: add dependency to build manual pages
"add_custom_command" outputs are only available as dependency in the same directory, so create a new target such it can be used from the main directory. This fixes the OS X build with no parallelism (-j1). Change-Id: I66aa5ae307be38ee715456a05fd55f55e4fa76e9 Reviewed-on: https://code.wireshark.org/review/18299 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Peter Wu <peter@lekensteyn.nl> Reviewed-by: Roland Knall <rknall@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9786ff4bf7..c5403a5243 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1931,6 +1931,7 @@ if(BUILD_wireshark AND QT_FOUND)
endif()
if(ENABLE_APPLICATION_BUNDLE)
+ add_dependencies(wireshark manpages)
set_target_properties(
wireshark PROPERTIES
MACOSX_BUNDLE_INFO_PLIST ${CMAKE_BINARY_DIR}/packaging/macosx/Info.plist