summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2013-10-11 11:11:41 +0000
committerJörg Mayer <jmayer@loplof.de>2013-10-11 11:11:41 +0000
commitf5fd46fe6d5ca4635c3423be9be30e51ab0427a5 (patch)
treea2320f81eacfedccb09e72785ae1a3312eb50574 /CMakeLists.txt
parent28282a991d3750b240e80250c1ea10b1bb4c0192 (diff)
downloadwireshark-f5fd46fe6d5ca4635c3423be9be30e51ab0427a5.tar.gz
qtshark and wireshark(gtk2) now actually find their libs.
svn path=/trunk/; revision=52539
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d629cdc8ec..3b71b6b69c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -374,7 +374,10 @@ if(BUILD_qtshark)
# Untested, may not work if CMAKE_PREFIX_PATH gets overwritten
# somewhere. The if WIN32 in this place is annoying as well.
if( WIN32 )
- set(CMAKE_PREFIX_PATH "C:\\Qt\\Qt5.1.1\\5.1.1\\msvc2010\\")
+ set( QT5_BASE_PATH "C:\\Qt\\Qt5.1.1\\5.1.1" )
+ set( CMAKE_PREFIX_PATH "${QT5_BASE_PATH}\\msvc2010" )
+ set( QT5_DLL_PATH "${CMAKE_PREFIX_PATH}/bin/dummy" )
+ set( WS_ALL_LIBS ${WS_ALL_LIBS} ${QT5_DLL_PATH} )
endif()
else()
set(PACKAGELIST ${PACKAGELIST} Qt4)
@@ -641,10 +644,6 @@ endif()
include(gmxTestLargeFiles)
gmx_test_large_files(GMX_LARGEFILES)
-#Platform specific
-#if(UNIX)
-#endif()
-
if(APPLE)
#
# We assume that APPLE means OS X so that we have the OS X