summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexis La Goutte <alexis.lagoutte@gmail.com>2017-02-20 14:54:16 +0100
committerAnders Broman <a.broman58@gmail.com>2017-02-21 05:40:59 +0000
commitfdecfa6c30adc71222e710016374299f01f7e7ad (patch)
tree6b30a2f6c6ce207be607f47926b97c0fe22e6435 /CMakeLists.txt
parent66e45419b16b2c742625d667c241ac4d05429b3f (diff)
downloadwireshark-fdecfa6c30adc71222e710016374299f01f7e7ad.tar.gz
cmake: Add some missing SET_FEATURE_INFO
for nghttp2, lz4, snappy Change-Id: I0788c2105b69ba2ae781709fb5e16e13b5ca1533 Reviewed-on: https://code.wireshark.org/review/20200 Petri-Dish: Alexis La Goutte <alexis.lagoutte@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c85b8c9da0..75d001162d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1353,7 +1353,9 @@ include(FeatureSummary)
SET_FEATURE_INFO(SBC "SBC Codec for Bluetooth A2DP stream playing" "http://git.kernel.org/cgit/bluetooth/sbc.git" )
SET_FEATURE_INFO(SPANDSP "Support for G.722 and G.726 codecs in RTP player" "http://www.soft-switch.org/" )
SET_FEATURE_INFO(LIBSSH "libssh is library for ssh connections and it is needed to build sshdump/ciscodump" "https://www.libssh.org/get-it/" )
-
+SET_FEATURE_INFO(LZ4 "LZ4 is lossless compression algorithm used in some protocol (CQL...)" "http://www.lz4.org" )
+SET_FEATURE_INFO(SNAPPY "snappy is a fast compressor/decompressor from Google used in some protocol (CQL, kafka...)" "http://google.github.io/snappy/")
+SET_FEATURE_INFO(NGHTTP2 "nghttp2 is used for header (de)compression (HPACK)" "http://www.nghttp2.org" )
FEATURE_SUMMARY(WHAT ALL)
link_directories(