summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJoerg Mayer <jmayer@loplof.de>2017-03-19 13:47:11 +0100
committerAnders Broman <a.broman58@gmail.com>2017-03-19 15:13:14 +0000
commit0b6b152694762bd5783569acbae48e9397d2b85f (patch)
tree4a26a51846b33e8d8182be87e25df3dfdab8cfcf /Makefile.am
parenta65c0c457668d7524dffefb17cc4e69a77a29f3c (diff)
downloadwireshark-0b6b152694762bd5783569acbae48e9397d2b85f.tar.gz
Remove echld/.
It has been unsupported for some years and when talking about removing it in the past I received some positive and no negative feedback. There is one instance of echld left: capchild/capture_sync.c: * echld might have already reaped the child. Can that case be removed or should be comment be updated to something more accurate? (left for a separate patch) Change-Id: Idac397158dd86fd0728eb95379449ee4a463fc28 Reviewed-on: https://code.wireshark.org/review/20619 Petri-Dish: Jörg Mayer <jmayer@loplof.de> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am31
1 files changed, 2 insertions, 29 deletions
diff --git a/Makefile.am b/Makefile.am
index 7708681cb5..ce7adf7f32 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -45,12 +45,11 @@ bin_PROGRAMS = \
@dumpcap_bin@ \
@reordercap_bin@ \
@rawshark_bin@ \
- @sharkd_bin@ \
- @echld_test_bin@
+ @sharkd_bin@
EXTRA_PROGRAMS = wireshark-gtk wireshark tshark tfshark capinfos captype \
editcap mergecap dftest randpkt text2pcap dumpcap reordercap \
- rawshark sharkd echld_test
+ rawshark sharkd
#
# Wireshark configuration files are put in $(pkgdatadir).
@@ -718,30 +717,6 @@ dftest_LDADD = \
@PCAP_LIBS@ \
${EPAN_EXTRA_LIBS}
-echld_test_SOURCES = \
- echld_test.c \
- capture_opts.c \
- capture_stop_conditions.c \
- cfile.c \
- conditions.c \
- ringbuffer.c \
- sync_pipe_write.c
-
-echld_test_CPPFLAGS = $(AM_CPPFLAGS) $(GLIB_CFLAGS)
-
-echld_test_LDADD = \
- epan/libwireshark.la \
- echld/libechld.la \
- writecap/libwritecap.a \
- wsutil/libwsutil.la \
- @GLIB_LIBS@ \
- @PCAP_LIBS@ \
- @C_ARES_LIBS@
-
-echld_test_DEPENDENCIES = \
- echld/libechld.la \
- epan/libwireshark.la
-
dumpcap_SOURCES = \
capture_opts.c \
capture_stop_conditions.c \
@@ -908,7 +883,6 @@ DIST_SUBDIRS = \
codecs \
doc \
epan \
- echld \
ui \
ui/cli \
ui/gtk \
@@ -932,7 +906,6 @@ SUBDIRS = \
epan \
capchild \
caputils \
- @echld_dir@ \
@plugins_dir@ \
packaging \
help \