summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2017-04-19 19:21:11 -0700
committerGuy Harris <guy@alum.mit.edu>2017-04-20 02:21:58 +0000
commit347a19ae9629ad06ab597a176672c9098c9af64a (patch)
tree859f885bc1280b9e920033562a87b251e84ecf56 /Makefile.am
parent9e8bc9fee87c99944bfe52e27498d759e7235701 (diff)
downloadwireshark-347a19ae9629ad06ab597a176672c9098c9af64a.tar.gz
Add common routines for command-line libwiretap error reporting.
These are similar to the routines added to ui/alert_box.c for dialog-box libwiretap error reporting. This centralizes the knowledge about what to say for various libwiretap errors, removing some duplicate code, and giving more details in some programs. Change-Id: I737405c4edaa0e6c27840f78a8c587a8b3ee120b Reviewed-on: https://code.wireshark.org/review/21234 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4209983d6b..d0e9378fe3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -667,6 +667,7 @@ editcap_CPPFLAGS = $(AM_CPPFLAGS) $(GLIB_CFLAGS)
# Libraries with which to link editcap.
editcap_LDADD = \
+ ui/libui.a \
wiretap/libwiretap.la \
wsutil/libwsutil.la \
@GLIB_LIBS@ \