summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2017-06-16 01:49:44 -0700
committerGuy Harris <guy@alum.mit.edu>2017-06-16 08:50:22 +0000
commit5039d0e57635589208e1d969a57250746e422e06 (patch)
tree455ae6bfd28a26c33ee4b8cbff8bbb1534380811 /Makefile.am
parent63b91ad3119c64eb8fdaa67303fe37d71a01a1b0 (diff)
downloadwireshark-5039d0e57635589208e1d969a57250746e422e06.tar.gz
Change some names to reflect Apple's new UNIX-for-Macs name.
{OS_X,os_x} -> {MACOS,macos}. Change-Id: Icebea6ab566c65996ee97bacb88fac7e84ec32de Reviewed-on: https://code.wireshark.org/review/22161 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index da3bab3341..d9294b5b00 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -988,7 +988,7 @@ libtool: $(LIBTOOL_DEPS)
#
install-data-local:
if BUILDING_WIRESHARK
-if NOT_OS_X
+if NOT_MACOS
mkdir -p $(DESTDIR)$(datadir)/mime/packages
install -m 644 $(srcdir)/wireshark-mime-package.xml $(DESTDIR)$(datadir)/mime/packages/wireshark.xml
mkdir -p $(DESTDIR)$(datadir)/appdata
@@ -1013,7 +1013,7 @@ endif
uninstall-local:
if BUILDING_WIRESHARK
-if NOT_OS_X
+if NOT_MACOS
rm -f $(DESTDIR)$(datadir)/appdata/wireshark.appdata.xml
rm -f $(DESTDIR)$(datadir)/applications/wireshark.desktop
rm -f $(DESTDIR)$(datadir)/applications/wireshark-gtk.desktop
@@ -1059,7 +1059,7 @@ uninstall-hook: update-databases-and-caches-uninstall
#
update-databases-and-caches-common:
if BUILDING_WIRESHARK
-if NOT_OS_X
+if NOT_MACOS
@echo "You may need to run \"ldconfig\" as root"
@echo "You may need to run \"update-desktop-database $(datadir)/applications\""
@echo "You may need to run \"update-mime-database $(datadir)/mime\""