summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-03-18 17:31:09 +0000
committerJoão Valverde <j@v6e.pt>2016-03-21 17:10:21 +0000
commit52dd4fb6330a10ed37b8e221c502b5a98de4f581 (patch)
tree9d3ea5b26003115f61ac5af0d9dd7997cbe7cfb2 /Makefile.am
parent69d348c12a2d86e5fa75189cd2dd5f4f3784dcfc (diff)
downloadwireshark-52dd4fb6330a10ed37b8e221c502b5a98de4f581.tar.gz
Fix building without extcap enabled
Using cmake -DENABLE_EXTCAP=no or ./configure --without-extcap. Some documentation fixes too. Change-Id: Iebf9c843d67e10a32de1a62904de8f88b872ec99 Reviewed-on: https://code.wireshark.org/review/14522 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 1a70f64973..5bc155e581 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -362,6 +362,10 @@ endif # HAVE_PLUGINS
include Makefile.common
+if HAVE_EXTCAP
+SHARK_COMMON_SRC += $(EXTCAP_COMMON_SRC)
+endif
+
if ENABLE_STATIC
EXTRALINKFLAGS = -Wl,-static -all-static
else
@@ -1391,7 +1395,7 @@ SUBDIRS = \
@wireshark_SUBDIRS@ \
ui/cli \
randpkt_core \
- extcap \
+ @extcap_subdir@ \
. \
doc