summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@zing.org>2015-01-18 13:27:13 -0800
committerGerald Combs <gerald@wireshark.org>2015-01-20 16:12:20 +0000
commit6e6a1291d0b36fe97d0f684e1abdfe546aaeae7f (patch)
treee441c514c057d4cadd74ae21ec6cc321b63ef285 /Makefile.am
parentaf3924a333aa8fc614ad45163751a614a9b9fc3d (diff)
downloadwireshark-6e6a1291d0b36fe97d0f684e1abdfe546aaeae7f.tar.gz
CMake: Set an output directory for plugins.
Redefine PLUGIN_DIR similar to DATAFILE_DIR and use it on all platforms. Add WiresharkPlugin.cmake so that we can start defining common macros for plugins/*/CMakeLists.txt. Load plugins in out-of-tree builds. Change-Id: I8c1359ed3cf8a71788b8320ff89dfe2d3969def2 Reviewed-on: https://code.wireshark.org/review/6640 Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1b9f743350..897d9a7255 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1247,6 +1247,7 @@ EXTRA_DIST = \
cmake/modules/FindPCAP.cmake \
cmake/modules/FindPOD.cmake \
cmake/modules/FindPORTAUDIO.cmake \
+ cmake/modules/FindPowerShell.cmake \
cmake/modules/FindSBC.cmake \
cmake/modules/FindSED.cmake \
cmake/modules/FindSETCAP.cmake \
@@ -1273,6 +1274,7 @@ EXTRA_DIST = \
cmake/modules/UseWinLibs.cmake \
cmake/modules/WiresharkConfig.cmake.in \
cmake/modules/WiresharkConfigVersion.cmake.in \
+ cmake/modules/WiresharkPlugin.cmake \
cmake/TestFileOffsetBits.c \
cmake/TestLargeFiles.c.cmakein \
cmake/TestWindowsFSeek.c \