summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2017-04-08 21:24:45 -0700
committerGuy Harris <guy@alum.mit.edu>2017-04-09 04:25:52 +0000
commit77cad8561cec1699d7a4317e34c5590d566c9eb8 (patch)
tree3f24eb8a1a898670b652d688157c50867d5e4617 /Makefile.am
parent62b342443ddf2e5089c9cbaf137dc6a81b0b4678 (diff)
downloadwireshark-77cad8561cec1699d7a4317e34c5590d566c9eb8.tar.gz
Move the filter file reading code to libui.
It doesn't belong in libwireshark, as it doesn't affect dissection, but it *does* belong in libui, as it's helper code for the UIs. Change-Id: I8a5e0640a299a08e9ec1917dd253197438ebfdbc Reviewed-on: https://code.wireshark.org/review/20974 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 1 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index ab43234aef..150dcb2f1e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -419,7 +419,6 @@ WIRESHARK_COMMON_SRC = \
capture_opts.c \
file.c \
fileset.c \
- filter_files.c \
summary.c \
ws_version_info.c
@@ -427,7 +426,6 @@ WIRESHARK_COMMON_SRC = \
WIRESHARK_COMMON_INCLUDES = \
capture_info.h \
capture_opts.h \
- filter_files.h \
globals.h \
log.h \
summary.h \
@@ -508,7 +506,6 @@ endif
tshark_SOURCES = \
$(SHARK_COMMON_SRC) \
capture_opts.c \
- filter_files.c \
tshark.c \
ws_version_info.c
@@ -580,7 +577,6 @@ rawshark_LDADD = \
sharkd_SOURCES = \
$(SHARK_COMMON_SRC) \
- filter_files.c \
sharkd.c \
sharkd.h \
sharkd_daemon.c \
@@ -722,7 +718,6 @@ dumpcap_SOURCES = \
capture_stop_conditions.c \
conditions.c \
dumpcap.c \
- filter_files.c \
ringbuffer.c \
sync_pipe_write.c \
ws_version_info.c
@@ -736,6 +731,7 @@ dumpcap_LDFLAGS = $(AM_LDFLAGS) $(PIE_LDFLAGS)
# Libraries with which to link dumpcap.
dumpcap_LDADD = \
caputils/libcaputils.a \
+ ui/libui.a \
writecap/libwritecap.a \
wsutil/libwsutil.la \
@GLIB_LIBS@ \