summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMichael Mann <mmann78@netscape.net>2016-02-28 17:32:13 -0500
committerMichael Mann <mmann78@netscape.net>2016-03-03 18:28:32 +0000
commit8435145b1fe1bcdc93bc48e26346739e9962686f (patch)
tree7775e36d4d5654cb04b1427701ea2d6b48e62f66 /Makefile.am
parentb70d1d7e14801754baee6af215b2162af38db211 (diff)
downloadwireshark-8435145b1fe1bcdc93bc48e26346739e9962686f.tar.gz
Create perl script to append existing AUTHORS file with information from git log.
new AUTHORS file can be created with "gen-authors" build parameter The "original" AUTHORS file has been fixed up to be kind to parsers (so no one gets excluded) and renamed to AUTHORS.src. This preserves the features authors worked on. For authors that didn't list features, they may be converted to just getting information from git. Change-Id: I9a4c4091e229f7f5e1c46d864527a98c1278e451 Reviewed-on: https://code.wireshark.org/review/14231 Petri-Dish: Michael Mann <mmann78@netscape.net> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c6a44a130c..18b2bcf2d6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1682,3 +1682,8 @@ if HAVE_DOXYGEN
rm -f wsar_html.zip
zip -rq wsar_html.zip wsar_html
endif
+
+gen-authors:
+#Generate list of AUTHORS (Name + E-Mail) sort by number of commit
+ git shortlog -sne | cut -c8- > $(top_srcdir)/AUTHORS.git
+ $(PERL) $(top_srcdir)/tools/generate_authors.pl $(top_srcdir)/AUTHORS.src $(top_srcdir)/AUTHORS.git > $(top_srcdir)/AUTHORS