summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-04-25 18:57:00 +0100
committerAnders Broman <a.broman58@gmail.com>2016-04-26 07:09:05 +0000
commit8a07ca87038acf414125776cce8ce932d375074f (patch)
tree70777624b0d99e7d867e94e95fdcf4ae4a2a9829 /Makefile.am
parentca57399db89b69a9ae8517f3e0ef530855c354bd (diff)
downloadwireshark-8a07ca87038acf414125776cce8ce932d375074f.tar.gz
Avoid making dist tarball if rpmbuild is missing
Fail sooner rather than later. Change-Id: If5740ee01d79f2eec87038cdbcb0725899735ff6 Reviewed-on: https://code.wireshark.org/review/15113 Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 72b598fa12..f92e7ad1b3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -967,8 +967,8 @@ svr4-package: $(PROGRAMS) $(SCRIPTS) $(MANS) $(DATA)
rpm_topdir=`cd $(top_builddir) && pwd`/packaging/rpm
-rpm-package: dist
if HAVE_RPM
+rpm-package: dist
@cd $(rpm_topdir) && \
mkdir -p BUILD RPMS SOURCES SRPMS && \
cd SOURCES && \
@@ -979,6 +979,7 @@ if HAVE_RPM
echo "Package successfully built in `pwd`/RPMS." ; \
rm -f SOURCES/$(distdir).tar.bz2 $(distdir).tar.bz2
else
+rpm-package:
@echo "RPM executable not available." ; \
false
endif