summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2008-12-13 00:58:43 +0000
committerGerald Combs <gerald@wireshark.org>2008-12-13 00:58:43 +0000
commit8a1109396a7295bc11f2eb474afc83ba3a1bc7f5 (patch)
treefa29d7e81b1b0da4ce653befb63402da35c17f98 /Makefile.am
parent097002bb0d8e1693935c8f7039c4277587bdba98 (diff)
downloadwireshark-8a1109396a7295bc11f2eb474afc83ba3a1bc7f5.tar.gz
Update faq.py to generate a full HTML document by default. Pull in a typo
fix from FAQ. Update the makefiles to build help/faq.txt and FAQ. Remove help/faq.txt and FAQ from the repository, since they're automatically generated now. Remove the make-faq script. svn path=/trunk/; revision=26980
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 958d61b625..7851751555 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -103,7 +103,7 @@ idl2wrs: tools/idl2wrs.sh Makefile
#
# Wireshark configuration files are put in $(pkgdatadir).
#
-pkgdata_DATA = AUTHORS-SHORT COPYING manuf services wireshark.html \
+pkgdata_DATA = AUTHORS-SHORT COPYING FAQ manuf services wireshark.html \
tshark.html wireshark-filter.html capinfos.html editcap.html \
idl2wrs.html mergecap.html text2pcap.html dumpcap.html \
rawshark.html ws.css cfilters colorfilters dfilters smi_modules
@@ -787,6 +787,11 @@ else
SUBDIRS = tools wsutil wiretap doc epan packaging help @wireshark_SUBDIRS@
endif
+FAQ: help/faq.txt help/faq.py
+ (cd help ; \
+ $(MAKE) faq.txt ; \
+ cp faq.txt ../FAQ )
+
wireshark.1: doc/wireshark.pod AUTHORS-SHORT-FORMAT
(cd doc ; \
$(MAKE) ../wireshark.1 )