summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2014-09-16 13:12:10 -0700
committerGerald Combs <gerald@wireshark.org>2014-09-16 20:16:26 +0000
commit983ae6cadee518be589b53d9b149fd2e156e8ada (patch)
tree5c6e62067121c2069354f3f6bff5c7df3c6d00a0 /Makefile.am
parenteefdaf6a64533611fec0b565d27113d3744de859 (diff)
downloadwireshark-983ae6cadee518be589b53d9b149fd2e156e8ada.tar.gz
Fix the patch-bzip2 target.
The main site URI scheme is now https. Update the URL in some other places while we're here. Change-Id: Ib03d4fd1c58dabd3cf5050dc4f79216e0b94d525 Reviewed-on: https://code.wireshark.org/review/4133 Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 397a51c9fd..2d3b9beafe 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1172,11 +1172,11 @@ BASE_VERSION=`echo "$(VERSION)" | awk -F. '{$$3 = $$3 + 0 ; printf("%d.%d.%d"),
PREV_VERSION=`echo "$(VERSION)" | awk -F. '{$$3 = $$3 + 0 ; if ($$3 > 0) $$3-- ; printf("%d.%d.%d"), $$1, $$2, $$3}'`
PREV_DIR="wireshark-$(PREV_VERSION)"
PREV_FILE="$(PREV_DIR).tar.bz2"
-PREV_URL="http://www.wireshark.org/download/src/all-versions/$(PREV_FILE)"
+PREV_URL="https://www.wireshark.org/download/src/all-versions/$(PREV_FILE)"
patch-bzip2: distdir
if test x$(BASE_VERSION) != x$(PREV_VERSION) ; then \
- curl -z $(PREV_FILE) -o $(PREV_FILE) $(PREV_URL) && \
+ curl --time-cond $(PREV_FILE) --location --output $(PREV_FILE) $(PREV_URL) && \
tar -xjf $(PREV_FILE) && \
diff -urN $(PREV_DIR) $(distdir) | bzip2 > patch-wireshark-$(PREV_VERSION)-to-$(VERSION).bz2 && \
echo "Created patch-bzip2" ; \