summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-03-22 05:49:00 +0000
committerJoão Valverde <j@v6e.pt>2016-03-25 00:16:19 +0000
commita1ed7314137dfa5a96e7600ea1d3c6d127697d59 (patch)
tree59cda41b7e61c97a28eb8b130e49291c930a429b /Makefile.am
parentb0db6a01a8de15a1eabb4a69135066034761dc2a (diff)
downloadwireshark-a1ed7314137dfa5a96e7600ea1d3c6d127697d59.tar.gz
Add ax_lib_socket_nsl.m4 macro
Add SOCKET_LIBS and NSL_LIBS to global LIBS variables on platforms where it is required. Make configure checks for getaddrinfo/gethostname unconditional, that is handled with #ifdefs if necessary. Change-Id: Ia874038454fb9cf3bdbf8e6fd829f319e331837e Reviewed-on: https://code.wireshark.org/review/14560 Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 0 insertions, 20 deletions
diff --git a/Makefile.am b/Makefile.am
index f096414730..90eb45abec 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -374,12 +374,6 @@ endif
# Libraries and plugin flags with which to link wireshark.
#
-# Note that Wireshark, when built with a version of GTK+ that runs
-# atop X11, doesn't have to be linked with @SOCKET_LIBS@ or @NSL_LIBS@,
-# as those should also be included in @GTK_LIBS@ (as those are also
-# needed for X applications, and GTK+ applications are X applications
-# if the version of GTK+ they're built with runs atop X11).
-#
# GTK_CFLAGS/GTK_LIBS is a strict superset of GLIB_CFLAGS/GLIB_LIBS
# (see configure.ac for pkg-config modules used).
#
@@ -450,8 +444,6 @@ tshark_LDADD = \
$(plugin_ldadd) \
@GLIB_LIBS@ \
@PCAP_LIBS@ \
- @SOCKET_LIBS@ \
- @NSL_LIBS@ \
@C_ARES_LIBS@ \
@KRB5_LIBS@ \
@SYSTEMCONFIGURATION_FRAMEWORKS@ \
@@ -475,8 +467,6 @@ tfshark_LDADD = \
$(plugin_ldadd) \
@GLIB_LIBS@ \
@PCAP_LIBS@ \
- @SOCKET_LIBS@ \
- @NSL_LIBS@ \
@KRB5_LIBS@ \
@SYSTEMCONFIGURATION_FRAMEWORKS@ \
@COREFOUNDATION_FRAMEWORKS@ \
@@ -498,8 +488,6 @@ rawshark_LDADD = \
$(plugin_ldadd) \
@GLIB_LIBS@ \
@PCAP_LIBS@ \
- @SOCKET_LIBS@ \
- @NSL_LIBS@ \
@C_ARES_LIBS@ \
@KRB5_LIBS@ \
@SYSTEMCONFIGURATION_FRAMEWORKS@ \
@@ -572,8 +560,6 @@ randpkt_LDADD = \
wsutil/libwsutil.la \
@GLIB_LIBS@ \
@PCAP_LIBS@ \
- @SOCKET_LIBS@ \
- @NSL_LIBS@ \
@C_ARES_LIBS@
dftest_CPPFLAGS = $(AM_CPPFLAGS) $(GLIB_CFLAGS)
@@ -588,8 +574,6 @@ dftest_LDADD = \
$(plugin_ldadd) \
@GLIB_LIBS@ \
@PCAP_LIBS@ \
- @SOCKET_LIBS@ \
- @NSL_LIBS@ \
@C_ARES_LIBS@ \
@KRB5_LIBS@ \
@LIBGCRYPT_LIBS@ \
@@ -605,8 +589,6 @@ echld_test_LDADD = \
wsutil/libwsutil.la \
@GLIB_LIBS@ \
@PCAP_LIBS@ \
- @SOCKET_LIBS@ \
- @NSL_LIBS@ \
@C_ARES_LIBS@
echld_test_DEPENDENCIES = \
@@ -626,8 +608,6 @@ dumpcap_LDADD = \
wsutil/libwsutil.la \
@GLIB_LIBS@ \
@PCAP_LIBS@ \
- @SOCKET_LIBS@ \
- @NSL_LIBS@ \
@SYSTEMCONFIGURATION_FRAMEWORKS@ \
@COREFOUNDATION_FRAMEWORKS@ \
@LIBCAP_LIBS@ \