summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2014-08-28 16:48:53 -0700
committerGerald Combs <gerald@wireshark.org>2014-09-02 15:39:17 +0000
commitb7fb1167e319ed2b1d1fd37f9844b8bc852ccb0d (patch)
tree4fe0e3ab63d6a6f4644daa82165ca035dd20cd30 /Makefile.am
parentb9e61becffc42f4b2d7981a0f468effbe9fa4b12 (diff)
downloadwireshark-b7fb1167e319ed2b1d1fd37f9844b8bc852ccb0d.tar.gz
Qt → wireshark. GTK+ → wireshark-gtk.
Make sure the Qt UI is named "Wireshark" and its executable is named "wireshark" or "wireshark.exe". Make sure the GTK+ UI is named "Wireshark 1" or "Wireshark (GTK+)" depending on how much the target audience is likely to care about UI toolkits. Make sure the GTK+ executable is named "wireshark-gtk" or "wireshark-gtk.exe". It looks like moving to Qt 5.3 (g978faf3) broke the PortableApps package. It's likely even more broken now. Autotools out-of-tree builds also broke on Ubuntu 12.02 (automake 1.11.3) at some point. The first attempt to compile in ui/qt returns "error: source_file.cpp: No such file or directory". The second attempt works. Out-of-tree builds work fine on Ubuntu 14.04 (automake 1.14.1). Tested: - Nmake builds - NSIS packaging - CMake builds (Windows, OS X) - Autotools build and distcheck - RPM packaging To do: - Test Debian packaging - Fix PortableApps Change-Id: I66429870e05fd2d6fc901942477959ed6164fce2 Reviewed-on: https://code.wireshark.org/review/3919 Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am55
1 files changed, 27 insertions, 28 deletions
diff --git a/Makefile.am b/Makefile.am
index dfa3fbaa05..397a51c9fd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -42,7 +42,7 @@ bin_PROGRAMS = \
@rawshark_bin@ \
@echld_test_bin@
-EXTRA_PROGRAMS = wireshark wireshark-qt tshark tfshark capinfos captype editcap \
+EXTRA_PROGRAMS = wireshark-gtk wireshark tshark tfshark capinfos captype editcap \
mergecap dftest randpkt text2pcap dumpcap reordercap rawshark \
wireshark_cxx echld_test
@@ -308,17 +308,17 @@ include Makefile.common
if ENABLE_STATIC
if HAVE_GTK
-wireshark_LDFLAGS = -Wl,-static -all-static
+wireshark_gtk_LDFLAGS = -Wl,-static -all-static
endif
if HAVE_Qt
-wireshark_qt_LDFLAGS = -Wl,-static -all-static
+wireshark_LDFLAGS = -Wl,-static -all-static
endif
else
if HAVE_GTK
-wireshark_LDFLAGS = -export-dynamic
+wireshark_gtk_LDFLAGS = -export-dynamic
endif
if HAVE_Qt
-wireshark_qt_LDFLAGS = -export-dynamic
+wireshark_LDFLAGS = -export-dynamic
endif
endif
@@ -344,7 +344,7 @@ endif
# although it's also possible that -lgmodule is in GTK_LIBS but not
# GLIB_LIBS (that's the case on my machine right now, for example).
#
-wireshark_ldadd = \
+wireshark_common_ldadd = \
capchild/libcapchild.a \
caputils/libcaputils.a \
ui/libui.a \
@@ -365,35 +365,35 @@ wireshark_ldadd = \
@LIBGCRYPT_LIBS@ \
@LIBGNUTLS_LIBS@ \
@LIBSMI_LDFLAGS@ \
- @PORTAUDIO_LIBS@ \
@GLIB_LIBS@ \
-lm
if HAVE_Qt
-wireshark_qt_SOURCES = $(WIRESHARK_COMMON_SRC)
-wireshark_qt_INCLUDES = $(WIRESHARK_COMMON_INCLUDES)
-wireshark_qt_CFLAGS = $(AM_CLEAN_CFLAGS)
-wireshark_qt_LDADD = \
+wireshark_SOURCES = $(WIRESHARK_COMMON_SRC)
+wireshark_INCLUDES = $(WIRESHARK_COMMON_INCLUDES)
+wireshark_CFLAGS = $(AM_CLEAN_CFLAGS)
+wireshark_LDADD = \
ui/qt/libqtui.a \
- $(wireshark_ldadd) \
+ $(wireshark_common_ldadd) \
@Qt_LIBS@
#
-# XXX - this makes wireshark_qt_LDFLAGS not work; we should figure out
-# another way to get wireshark-qt linked as a C++ program, perhaps by
+# XXX - this makes wireshark_LDFLAGS not work; we should figure out
+# another way to get wireshark linked as a C++ program, perhaps by
# having a top-level wireshark-qt.cpp file that contains main() and
-# hthat calls the UI code from ui/qt.
+# that calls the UI code from ui/qt.
#
-wireshark_qt_LINK = $(CXXLINK)
+wireshark_LINK = $(CXXLINK)
endif
if HAVE_GTK
-wireshark_SOURCES = $(WIRESHARK_COMMON_SRC)
-wireshark_INCLUDES = $(WIRESHARK_COMMON_INCLUDES)
-wireshark_CFLAGS = $(AM_CLEAN_CFLAGS)
-wireshark_LDADD = \
+wireshark_gtk_SOURCES = $(WIRESHARK_COMMON_SRC)
+wireshark_gtk_INCLUDES = $(WIRESHARK_COMMON_INCLUDES)
+wireshark_gtk_CFLAGS = $(AM_CLEAN_CFLAGS)
+wireshark_gtk_LDADD = \
ui/gtk/libgtkui.a \
- $(wireshark_ldadd) \
+ $(wireshark_common_ldadd) \
+ @PORTAUDIO_LIBS@ \
@GTK_LIBS@
endif
@@ -775,12 +775,12 @@ EXTRA_DIST = \
debian/wireshark-dev.manpages \
debian/wireshark-dev.prerm \
debian/wireshark-doc.docs \
- debian/wireshark-qt.docs \
- debian/wireshark-qt.install \
- debian/wireshark.docs \
- debian/wireshark.install \
+ debian/wireshark-gtk.docs \
+ debian/wireshark-gtk.install \
debian/wireshark.manpages \
debian/wireshark.menu \
+ debian/wireshark-qt.docs \
+ debian/wireshark-qt.install \
dfilters \
doxygen_global.cfg \
doxygen.cfg.in \
@@ -1297,8 +1297,8 @@ checkapi_local:
$(PERL) $(top_srcdir)/tools/checkAPIs.pl -build \
-sourcedir=$(srcdir) \
$(TSHARK_TAP_SRC) \
- $(wireshark_SOURCES)
-# $(EXTRA_wireshark_SOURCES)
+ $(wireshark_gtk_SOURCES)
+# $(EXTRA_wireshark_gtk_SOURCES)
checkapi: checkapi_local
cd wiretap && $(MAKE) checkapi
@@ -1331,4 +1331,3 @@ if HAVE_DOXYGEN
rm -f wsar_html.zip
zip -rq wsar_html.zip wsar_html
endif
-