summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-12-03 23:56:10 -0800
committerGuy Harris <guy@alum.mit.edu>2014-12-04 07:56:48 +0000
commitc02417f851c951ce31b54c4d85934250a9c9df64 (patch)
tree23d93ce7f05e1d079e228a0a2e7bfc7475969d67 /Makefile.am
parent6e5d84f1e1ce5cb468f585c0bdb26d555254d107 (diff)
downloadwireshark-c02417f851c951ce31b54c4d85934250a9c9df64.tar.gz
Don't do all the fd.o desktop integration stuff on OS X.
It doesn't need it, so don't install those files, or uninstall them, or suggest running various unnecessary commands after the installation finishes. Change-Id: Ieecab22884723670f47f2fc7cc1ac827f48c1967 Reviewed-on: https://code.wireshark.org/review/5614 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1fee891a2b..7157167a63 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1423,7 +1423,10 @@ patch-bzip2: distdir
# FreeBSD install command has a -T flag that takes an argument and
# that has completely different semantics.
#
+# We neither need nor want any of this on OS X.
+#
install-data-local:
+if NOT_OS_X
mkdir -p $(DESTDIR)$(datadir)/mime/packages
install -m 644 $(srcdir)/wireshark-mime-package.xml $(DESTDIR)$(datadir)/mime/packages/wireshark.xml
mkdir -p $(DESTDIR)$(datadir)/applications
@@ -1441,8 +1444,10 @@ install-data-local:
done
mkdir -p $(DESTDIR)$(datadir)/icons/hicolor/scalable/apps
install -m 644 $(srcdir)/image/wsicon.svg $(DESTDIR)$(datadir)/icons/hicolor/scalable/apps/wireshark.svg
+endif
uninstall-local:
+if NOT_OS_X
rm -f $(DESTDIR)$(datadir)/mime/packages/wireshark.xml
rm -f $(DESTDIR)$(datadir)/applications/wireshark.desktop
for size in 16 24 32 48 64 128 256; \
@@ -1451,6 +1456,7 @@ uninstall-local:
rm -f $(DESTDIR)$(datadir)/icons/hicolor/$${size}x$${size}/mimetypes/application-wireshark-doc.png ; \
done
rm -f $(DESTDIR)$(datadir)/icons/hicolor/scalable/apps/wireshark.svg
+endif
install-data-hook: update-databases-and-caches-install
uninstall-hook: update-databases-and-caches-uninstall
@@ -1481,17 +1487,25 @@ uninstall-hook: update-databases-and-caches-uninstall
#
# The update-alternatives suggestions need work.
#
+# We neither need nor want any of this on OS X.
+#
update-databases-and-caches-common:
+if NOT_OS_X
@echo "You may need to run \"ldconfig\" as root"
@echo "You may need to run \"update-desktop-database $(datadir)/applications\""
@echo "You may need to run \"update-mime-database $(datadir)/mime\""
@echo "You may need to run \"gtk-update-icon-cache -f -t $(datadir)/icons/hicolor\""
+endif
update-databases-and-caches-install: update-databases-and-caches-common
+if NOT_OS_X
@echo "You may need to run \"update-alternatives --install $(bindir)/wireshark wireshark $(bindir)/wireshark-qt 50\""
+endif
update-databases-and-caches-uninstall: update-databases-and-caches-common
+if NOT_OS_X
@echo "You may need to run \"update-alternatives --remove wireshark $(bindir)/wireshark-qt\""
+endif
# Used by svr4-package and osx-package
# We load top_stagedir with an absolute path so that libtool doesn't freak.