summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss@ulticom.com>2008-09-18 13:31:14 +0000
committerJeff Morriss <jeff.morriss@ulticom.com>2008-09-18 13:31:14 +0000
commitdcca906f30a32c4522d3cbbc387a347953187c20 (patch)
tree1df8be1393e206a41e42fe6cc7138f725e270864 /Makefile.am
parent1882e64736afbb2d61ce539d9262064410b33dce (diff)
downloadwireshark-dcca906f30a32c4522d3cbbc387a347953187c20.tar.gz
http://www.gnu.org/software/libtool/manual/libtool.html#Inter_002dlibrary-dependencies
says: "However, most shared library systems are restricted in that they only allow a single level of dependencies. In these systems, programs may depend on shared libraries, but shared libraries may not depend on other shared libraries." So reverse the top-level Makefile.am change of rev 26218. That is: link the executables against libwsutil again. This hopefully will fix: https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=1677#c23 svn path=/trunk/; revision=26227
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 269ca471cf..29580b12a6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -310,6 +310,7 @@ wireshark_LDADD = \
codecs/libcodec.a \
wiretap/libwiretap.la \
epan/libwireshark.la \
+ wsutil/libwsutil.la \
@INET_PTON_LO@ \
@INET_NTOP_LO@ \
@SSL_LIBS@ \
@@ -337,6 +338,7 @@ tshark_LDADD = \
$(wireshark_optional_objects) \
wiretap/libwiretap.la \
epan/libwireshark.la \
+ wsutil/libwsutil.la \
@INET_PTON_LO@ \
@INET_NTOP_LO@ \
@SSL_LIBS@ \
@@ -365,6 +367,7 @@ rawshark_LDADD = \
$(wireshark_optional_objects) \
wiretap/libwiretap.la \
epan/libwireshark.la \
+ wsutil/libwsutil.la \
@INET_PTON_LO@ \
@INET_NTOP_LO@ \
@SSL_LIBS@ \
@@ -390,26 +393,31 @@ text2pcap_optional_objects = @STRERROR_O@ @STRPTIME_O@
text2pcap_LDADD = \
$(text2pcap_optional_objects) \
wiretap/libwiretap.la \
+ wsutil/libwsutil.la \
@GLIB_LIBS@ -lm
# Libraries with which to link mergecap.
mergecap_LDADD = \
wiretap/libwiretap.la \
+ wsutil/libwsutil.la \
@GLIB_LIBS@
# Libraries with which to link capinfos.
capinfos_LDADD = \
wiretap/libwiretap.la \
+ wsutil/libwsutil.la \
@GLIB_LIBS@
# Libraries with which to link editcap.
editcap_LDADD = \
wiretap/libwiretap.la \
+ wsutil/libwsutil.la \
@GLIB_LIBS@
# Libraries with which to link randpkt.
randpkt_LDADD = \
wiretap/libwiretap.la \
+ wsutil/libwsutil.la \
@GLIB_LIBS@ -lm \
@PCAP_LIBS@ \
@SOCKET_LIBS@ \
@@ -421,6 +429,7 @@ randpkt_LDADD = \
dftest_LDADD = \
$(wireshark_optional_objects) \
wiretap/libwiretap.la \
+ wsutil/libwsutil.la \
epan/libwireshark.la \
@SSL_LIBS@ \
$(plugin_ldadd) \
@@ -439,6 +448,7 @@ dftest_LDADD = \
# Libraries with which to link dumpcap.
dumpcap_LDADD = \
wiretap/libwiretap.la \
+ wsutil/libwsutil.la \
@INET_NTOP_LO@ \
@GLIB_LIBS@ \
@PCAP_LIBS@ \