summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2016-07-27 15:31:06 -0700
committerJoão Valverde <j@v6e.pt>2016-07-29 10:55:34 +0000
commitf5dff39232f98db9b9d60bf05a64eab98868aa59 (patch)
tree1896f4194ac453ffcff632f7210347ba8906e91f /Makefile.am
parente727ecf5e302c9f765d0038b234e6775fb4ca45b (diff)
downloadwireshark-f5dff39232f98db9b9d60bf05a64eab98868aa59.tar.gz
Use xz to compress the source tarball.
Compress the source tarball using xz instead of bzip2. Other open source projects (including many of our dependencies) have been using xz for a while so hopefully this won't be too much of a shock. Remove the patch-bzip2 Autotools target while we're here. Change-Id: I456d27b6cd56a43aba829bd45938f98568eb7b1d Reviewed-on: https://code.wireshark.org/review/16735 Reviewed-by: Gerald Combs <gerald@wireshark.org> Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 2 insertions, 22 deletions
diff --git a/Makefile.am b/Makefile.am
index ed3aafd1cc..67ba8cd2d9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -936,26 +936,6 @@ libtool: $(LIBTOOL_DEPS)
$(SHELL) ./config.status --recheck
-# Used by patch-bzip2
-# Trim off any extra version information and find the previous micro release.
-BASE_VERSION=`echo "$(VERSION)" | awk -F. '{$$3 = $$3 + 0 ; printf("%d.%d.%d"), $$1, $$2, $$3}'`
-PREV_VERSION=`echo "$(VERSION)" | awk -F. '{$$3 = $$3 + 0 ; if ($$3 > 0) $$3-- ; printf("%d.%d.%d"), $$1, $$2, $$3}'`
-PREV_DIR="wireshark-$(PREV_VERSION)"
-PREV_FILE="$(PREV_DIR).tar.bz2"
-PREV_URL="https://www.wireshark.org/download/src/all-versions/$(PREV_FILE)"
-
-patch-bzip2: distdir
- if test x$(BASE_VERSION) != x$(PREV_VERSION) ; then \
- curl --time-cond $(PREV_FILE) --location --output $(PREV_FILE) $(PREV_URL) && \
- tar -xjf $(PREV_FILE) && \
- diff -urN $(PREV_DIR) $(distdir) | bzip2 > patch-wireshark-$(PREV_VERSION)-to-$(VERSION).bz2 && \
- echo "Created patch-bzip2" ; \
- rm -rf "$(PREV_FILE)" "$(PREV_DIR)" ; \
- else \
- echo "This appears to be the first micro version ($(PREV_VERSION)). Skipping." ; \
- fi
- $(am__remove_distdir)
-
#
# Install icons and other desktop files for (for use with GNOME, KDE, or
# any other freedesktop.org-compliant desktops).
@@ -1118,12 +1098,12 @@ rpm-package: dist
@cd $(rpm_topdir) && \
mkdir -p BUILD RPMS SOURCES SRPMS && \
cd SOURCES && \
- ln -sf ../../../$(distdir).tar.bz2 && \
+ ln -sf ../../../$(distdir).tar.xz && \
cd .. && \
$(RPMBUILD) --define "_topdir `cd . && pwd`" --define "_prefix $(prefix)" \
@RPMBUILD_WITH_ARGS@ --clean -ba SPECS/wireshark.spec && \
echo "Package successfully built in `pwd`/RPMS." ; \
- rm -f SOURCES/$(distdir).tar.bz2 ../../$(distdir).tar.bz2
+ rm -f SOURCES/$(distdir).tar.xz ../../$(distdir).tar.xz
else
rpm-package:
@echo "RPM executable not available." ; \