summaryrefslogtreecommitdiff
path: root/capchild/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-06-21 05:06:23 +0100
committerJoão Valverde <j@v6e.pt>2016-06-30 11:04:17 +0000
commita16d401b25c85ffb7fde6c46b51cb7048112f885 (patch)
tree71ba692edcdb6f2a10ed566e18bcfbbc456cfad1 /capchild/Makefile.am
parentf6c5cf953212248cbc680ef0d9b2f852cbfdb951 (diff)
downloadwireshark-a16d401b25c85ffb7fde6c46b51cb7048112f885.tar.gz
Remove Makefile.common files
Now that nmake build system has been removed they are not needed anymore. Change-Id: I88075f955bb4349185859c1af4be22e53de5850f Reviewed-on: https://code.wireshark.org/review/16050 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'capchild/Makefile.am')
-rw-r--r--capchild/Makefile.am32
1 files changed, 15 insertions, 17 deletions
diff --git a/capchild/Makefile.am b/capchild/Makefile.am
index 74d49969ff..5a50b68eea 100644
--- a/capchild/Makefile.am
+++ b/capchild/Makefile.am
@@ -19,29 +19,33 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-include Makefile.common
include $(top_srcdir)/Makefile.am.inc
AM_CPPFLAGS = $(INCLUDEDIRS) $(WS_CPPFLAGS) $(GLIB_CFLAGS)
noinst_LIBRARIES = libcapchild.a
+# All sources that should be put in the source distribution tarball
+libcapchild_a_SOURCES = \
+ capture_ifinfo.c \
+ capture_sync.c \
+ capture_session.h \
+ capture_sync.h
+
+libcapchild_a_DEPENDENCIES =
+
+EXTRA_DIST = \
+ CMakeLists.txt \
+ doxygen.cfg.in
+
CLEANFILES = \
doxygen-capchild.tag \
libcapchild.a \
*~
MAINTAINERCLEANFILES = \
- $(GENERATED_FILES) \
Makefile.in
-# All sources that should be put in the source distribution tarball
-libcapchild_a_SOURCES = \
- $(CAPCHILD_SRC) \
- $(noinst_HEADERS)
-
-libcapchild_a_DEPENDENCIES =
-
doxygen:
if HAVE_DOXYGEN
$(DOXYGEN) doxygen.cfg
@@ -57,15 +61,9 @@ checkapi: checkapi-base checkapi-todo
checkapi-base:
$(PERL) $(top_srcdir)/tools/checkAPIs.pl -g deprecated-gtk -build \
-sourcedir=$(srcdir) \
- $(CAPCHILD_SRC)
+ $(libcapchild_a_SOURCES)
checkapi-todo:
$(PERL) $(top_srcdir)/tools/checkAPIs.pl -M -g deprecated-gtk-todo -build \
-sourcedir=$(srcdir) \
- $(CAPCHILD_SRC)
-
-EXTRA_DIST = \
- $(GENERATOR_FILES) \
- CMakeLists.txt \
- doxygen.cfg.in \
- Makefile.common \ No newline at end of file
+ $(libcapchild_a_SOURCES)