summaryrefslogtreecommitdiff
path: root/caputils/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2015-11-25 00:45:06 +0000
committerAlexis La Goutte <alexis.lagoutte@gmail.com>2015-11-27 22:22:06 +0000
commit7c8314a68340a331c43f3232f6158a9c3afff641 (patch)
tree2e648c0dc0c755e8820c9b0bfc3a8b66ea560d43 /caputils/Makefile.am
parentd7f12436709e40d58d7fcdfbcdd08740c039e162 (diff)
downloadwireshark-7c8314a68340a331c43f3232f6158a9c3afff641.tar.gz
Fix ISO C forbids an empty translation unit [-Wpedantic] (airpcap)
Autotools only warning. Change-Id: I30f33d2f8611d662dbc62326862707bf05ad3f60 Reviewed-on: https://code.wireshark.org/review/12150 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Peter Wu <peter@lekensteyn.nl> Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com>
Diffstat (limited to 'caputils/Makefile.am')
-rw-r--r--caputils/Makefile.am33
1 files changed, 20 insertions, 13 deletions
diff --git a/caputils/Makefile.am b/caputils/Makefile.am
index fe3d5735e0..1710d8b587 100644
--- a/caputils/Makefile.am
+++ b/caputils/Makefile.am
@@ -31,6 +31,10 @@ noinst_LIBRARIES = libcaputils.a
PLATFORM_CAPUTILS_SRC = \
capture-pcap-util-unix.c
+CAPUTILS_SRC = \
+ $(COMMON_CAPUTILS_SRC) \
+ $(PLATFORM_CAPUTILS_SRC)
+
CLEANFILES = \
doxygen-caputils.tag \
libcaputils.a \
@@ -40,6 +44,22 @@ MAINTAINERCLEANFILES = \
$(GENERATED_FILES) \
Makefile.in
+EXTRA_DIST = \
+ $(GENERATOR_FILES) \
+ airpcap.h \
+ airpcap_loader.c \
+ airpcap_loader.h \
+ capture_win_ifnames.c \
+ capture_win_ifnames.h \
+ capture-wpcap.c \
+ capture-wpcap.h \
+ capture_wpcap_packet.c \
+ capture_wpcap_packet.h \
+ CMakeLists.txt \
+ doxygen.cfg.in \
+ Makefile.common \
+ Makefile.nmake
+
# All sources that should be put in the source distribution tarball
libcaputils_a_SOURCES = \
$(CAPUTILS_SRC) \
@@ -80,16 +100,3 @@ checkapi-todo:
$(PERL) $(top_srcdir)/tools/checkAPIs.pl -M -g deprecated-gtk-todo -build \
-sourcedir=$(srcdir) \
$(CAPUTILS_SRC)
-
-EXTRA_DIST = \
- $(GENERATOR_FILES) \
- capture_win_ifnames.c \
- capture_win_ifnames.h \
- capture-wpcap.c \
- capture-wpcap.h \
- capture_wpcap_packet.c \
- capture_wpcap_packet.h \
- CMakeLists.txt \
- doxygen.cfg.in \
- Makefile.common \
- Makefile.nmake