summaryrefslogtreecommitdiff
path: root/caputils/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-07-04 00:24:02 -0700
committerGuy Harris <guy@alum.mit.edu>2014-07-04 07:25:26 +0000
commit9e6487f24751d1c1a047ee82e158077ac67c9c68 (patch)
tree3cc4a8524062948f4951914dc9af489e0d7c4572 /caputils/Makefile.am
parentc5643a3d257909ed3e8752cd729b9192ae719683 (diff)
downloadwireshark-9e6487f24751d1c1a047ee82e158077ac67c9c68.tar.gz
Move utility routines for capturing into a libcaputils static library.
Some of those routines are used only in dumpcap; others are used in TShark and Wireshark as well. Change-Id: I9d92483f2fcff57a7d8b6bf6bdf2870505d19fb7 Reviewed-on: https://code.wireshark.org/review/2841 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'caputils/Makefile.am')
-rw-r--r--caputils/Makefile.am89
1 files changed, 89 insertions, 0 deletions
diff --git a/caputils/Makefile.am b/caputils/Makefile.am
new file mode 100644
index 0000000000..ad0326f5a5
--- /dev/null
+++ b/caputils/Makefile.am
@@ -0,0 +1,89 @@
+# Makefile.am
+# Automake file for the "capture utilities" routines for Wireshark
+#
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
+# Copyright 1998 Gerald Combs
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+include Makefile.common
+include ../Makefile.am.inc
+
+if HAVE_WARNINGS_AS_ERRORS
+AM_CLEAN_CFLAGS = -Werror
+endif
+
+noinst_LIBRARIES = libcaputils.a
+
+PLATFORM_CAPUTILS_SRC = \
+ capture-pcap-util-unix.c
+
+CLEANFILES = \
+ doxygen-caputils.tag \
+ libcaputils.a \
+ *~
+
+MAINTAINERCLEANFILES = \
+ $(GENERATED_FILES) \
+ Makefile.in
+
+# All sources that should be put in the source distribution tarball
+libcaputils_a_SOURCES = \
+ $(CAPUTILS_SRC) \
+ $(noinst_HEADERS)
+
+libcaputils_a_CFLAGS = $(AM_CLEAN_CFLAGS)
+
+libcaputils_a_DEPENDENCIES =
+
+# Common headers
+AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/wiretap $(LIBGCRYPT_CFLAGS) $(LIBGNUTLS_CFLAGS) $(PORTAUDIO_INCLUDES)
+
+
+doxygen:
+if HAVE_DOXYGEN
+ $(DOXYGEN) doxygen.cfg
+endif # HAVE_DOXYGEN
+
+wsar_html: doxygen.cfg ../doxygen_global.cfg
+if HAVE_DOXYGEN
+ (umask 022 ; $(DOXYGEN) doxygen.cfg)
+endif
+
+checkapi: checkapi-base checkapi-todo
+
+checkapi-base:
+ $(PERL) $(top_srcdir)/tools/checkAPIs.pl -g deprecated-gtk -build \
+ -sourcedir=$(srcdir) \
+ $(CAPUTILS_SRC)
+
+checkapi-todo:
+ $(PERL) $(top_srcdir)/tools/checkAPIs.pl -M -g deprecated-gtk-todo -build \
+ -sourcedir=$(srcdir) \
+ $(CAPUTILS_SRC)
+
+EXTRA_DIST = \
+ $(GENERATOR_FILES) \
+ capture_win_ifnames.c \
+ capture_win_ifnames.h \
+ capture-wpcap.c \
+ capture-wpcap.h \
+ capture_wpcap_packet.c \
+ capture_wpcap_packet.h \
+ CMakeLists.txt \
+ doxygen.cfg.in \
+ Makefile.common \
+ Makefile.nmake