summaryrefslogtreecommitdiff
path: root/codecs/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2006-09-02 06:39:43 +0000
committerGuy Harris <guy@alum.mit.edu>2006-09-02 06:39:43 +0000
commit0ec3e5661f5c12731a69a15d4a1d1ef6ca19aa66 (patch)
tree833928513cb31527c5bd1c334f234af05cef8dd6 /codecs/Makefile.am
parente7135c63bb5a3b13b02a5513cae346d68f209bd5 (diff)
downloadwireshark-0ec3e5661f5c12731a69a15d4a1d1ef6ca19aa66.tar.gz
Move the codecs into a top-level "codecs" subdirectory; there's no
guarantee that all programs using the codecs will necessarily be using GTK+. svn path=/trunk/; revision=19117
Diffstat (limited to 'codecs/Makefile.am')
-rw-r--r--codecs/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/codecs/Makefile.am b/codecs/Makefile.am
new file mode 100644
index 0000000000..6eb1a4c056
--- /dev/null
+++ b/codecs/Makefile.am
@@ -0,0 +1,42 @@
+# Makefile.am
+# Automake file for the codecs for Wireshark
+#
+# $Id$
+#
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@xxxxxxxxxxxxx>
+# Copyright 1998 Gerald Combs
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+
+noinst_LIBRARIES = libcodec.a
+
+CLEANFILES = \
+ libcodec.a \
+ *~
+
+MAINTAINERCLEANFILES = \
+ Makefile.in
+
+libcodec_a_SOURCES = \
+ G711a/G711adecode.c G711a/G711adecode.h G711a/G711atable.h \
+ G711u/G711udecode.c G711u/G711udecode.h G711u/G711utable.h
+
+libcodec_a_DEPENDENCIES =
+
+EXTRA_DIST = \
+ Makefile.nmake
+