summaryrefslogtreecommitdiff
path: root/codecs/Makefile.am
diff options
context:
space:
mode:
authorStephen Fisher <steve@stephen-fisher.com>2007-03-22 23:03:39 +0000
committerStephen Fisher <steve@stephen-fisher.com>2007-03-22 23:03:39 +0000
commitcdf47e536bc77c178a630f5bf474b7ba148394fd (patch)
tree29f085b19c89a9bba21ab7461a300809b9bfe12d /codecs/Makefile.am
parent7f3e4fea48dad56d9ecfb73aab614233cdde5a0e (diff)
downloadwireshark-cdf47e536bc77c178a630f5bf474b7ba148394fd.tar.gz
Add -Werror when using GCC only to the Makefile.am of the base
directory and most of the plugins to match the same command put in the Makefile.nmake files for Windows compliations. Fix a few warnings when compiling under gcc 3.4.4 on FreeBSD. Create new automake file variable called USING_GCC in configure.in and wiretap/configure.in to acomplish the above -Werror addition. svn path=/trunk/; revision=21127
Diffstat (limited to 'codecs/Makefile.am')
-rw-r--r--codecs/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/codecs/Makefile.am b/codecs/Makefile.am
index 6eb1a4c056..a68fd61a63 100644
--- a/codecs/Makefile.am
+++ b/codecs/Makefile.am
@@ -21,6 +21,9 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+if USING_GCC
+AM_CFLAGS = -Werror
+endif
noinst_LIBRARIES = libcodec.a