summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2016-07-14 12:32:48 -0700
committerGerald Combs <gerald@wireshark.org>2016-07-14 19:34:39 +0000
commit06ba81b4f1acb371f7cbc2e351f6769a7d2627db (patch)
tree35df4bf021974024a28a2fa6bba610ddeddc88b0 /configure.ac
parent36e8a6c3ee6127bb4b92d29ed558613be59c6d5d (diff)
downloadwireshark-06ba81b4f1acb371f7cbc2e351f6769a7d2627db.tar.gz
Build 2.1.1, second try.
The buildbots that create packages run `perl make-version.pl --set-release` at the beginning of each build. This in turn sets the extra version information for our generated packages to "-g<abbreviated hash>" for development builds, or "" (an empty string) for release builds. Hardcoding the extra version information to "-git" in CMakeLists.txt and configure.ac means we end up with wireshark-2.1.0-git.tar.bz2, Wireshark-win64-2.1.0-git.exe, etc. for release builds. Set them back to empty strings. Change-Id: Icdfb248d25ad4adbc9abe0bd938e410590e42828 Reviewed-on: https://code.wireshark.org/review/16439 Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index caa29a32a6..f194e94477 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,7 +9,7 @@ m4_define([version_major], [2])
m4_define([version_minor], [1])
m4_define([version_micro], [1])
dnl Updated by make-version.pl
-m4_define([version_extra], [-git])
+m4_define([version_extra], [])
m4_define([version_micro_extra], m4_join([], version_micro, version_extra))
AC_INIT(Wireshark, [version_major.version_minor.version_micro_extra], http://bugs.wireshark.org/, , http://www.wireshark.org/)