summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2013-09-30 10:20:43 +0000
committerGerald Combs <gerald@wireshark.org>2013-09-30 10:20:43 +0000
commit0a75c9d87291d2cdd56724c470e29f2668116c31 (patch)
tree7239ed55bbd062a45c9932d0e10c76ddaebd3d9e /configure.ac
parentacf8fbb75deb3150fee28602756abf982a67ef3b (diff)
downloadwireshark-0a75c9d87291d2cdd56724c470e29f2668116c31.tar.gz
Start migrating the OS X app bundle to Qt. This will likely break the
installers. svn path=/trunk/; revision=52292
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 90e7c5bde2..75dc88a6a2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1137,7 +1137,6 @@ esac
AC_SUBST(APPLICATIONSERVICES_FRAMEWORKS)
AC_SUBST(SYSTEMCONFIGURATION_FRAMEWORKS)
AC_SUBST(COREFOUNDATION_FRAMEWORKS)
-AC_SUBST(OSX_APP_FLAGS)
#
# On Solaris, check whether we have getexecname().
@@ -1346,6 +1345,7 @@ if test "x$enable_wireshark" = "xyes"; then
CXXFLAGS="$CXXFLAGS $Qt_CFLAGS"
have_qt=yes
GUI_CONFIGURE_FLAGS="$GUI_CONFIGURE_FLAGS --with-qt"
+ OSX_APP_FLAGS="$OSX_APP_FLAGS -qt"
],
[AC_MSG_ERROR([Qt is not available])])
@@ -1700,6 +1700,7 @@ AC_SUBST(wireshark_bin)
AC_SUBST(wireshark_man)
AM_CONDITIONAL(HAVE_Qt, test "$have_qt" = "yes")
AM_CONDITIONAL(HAVE_GTK, test "$have_gtk" = "yes")
+AC_SUBST(OSX_APP_FLAGS)
# Enable/disable tshark