summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2012-12-09 04:18:52 +0000
committerGuy Harris <guy@alum.mit.edu>2012-12-09 04:18:52 +0000
commit0fbf4b5b1c9bac5b33251c35c9eca9cc848a5402 (patch)
tree15ee61537fcbbb442c08a228cafd2fdc45871769 /configure.ac
parent8d7e398dc74ca2e14920cff4423369cbe7a93093 (diff)
downloadwireshark-0fbf4b5b1c9bac5b33251c35c9eca9cc848a5402.tar.gz
Put back the extra checks for -Wshadow; I guess I'll need to set up a
Ubuntu 12 VM to figure out why -Wshadow was rejected, as it doesn't seem to cause bogus errors. svn path=/trunk/; revision=46477
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e6278d32e5..508d295ebc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -435,7 +435,19 @@ AC_WIRESHARK_GCC_CFLAGS_CHECK(-Wold-style-definition, C)
# some Xcode versions that came with Mac OS X 10.5) complain about
# that.
#
-AC_WIRESHARK_GCC_CFLAGS_CHECK(-Wshadow, C)
+AC_WIRESHARK_GCC_CFLAGS_CHECK(-Wshadow, C,
+ [
+extern int atoi(char *p);
+
+int
+foo(char *p)
+{
+ int (*fptr)(char *p) = atoi;
+
+ return fptr(p) * 2;
+}
+ ],
+ [warns about variables in function declarations shadowing other variables])
AC_WIRESHARK_GCC_CFLAGS_CHECK(-Wno-error=unused-but-set-variable) ## for now
#
# Use the faster pre gcc 4.5 floating point precision if available;