summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-03-22 21:03:18 +0000
committerJoão Valverde <j@v6e.pt>2016-03-23 02:15:32 +0000
commit125989780ba8e658ad0d1f1c71ec01e6d36a2266 (patch)
treefe4427342ea7c8be5292c3a9e2ab060eb2d25bc3 /configure.ac
parented350dd350e7b02a53d305d4330aa0b545d2eea3 (diff)
downloadwireshark-125989780ba8e658ad0d1f1c71ec01e6d36a2266.tar.gz
configure.ac: Remove --enable-usr-local
Let the compiler and linker handle the system default search path. Generally give priority to /usr/local when doing "manual" searches. Change-Id: I3bde7af1226305d94ddb4bc96cefe9ef91e26769 Reviewed-on: https://code.wireshark.org/review/14564 Petri-Dish: Alexis La Goutte <alexis.lagoutte@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 0 insertions, 32 deletions
diff --git a/configure.ac b/configure.ac
index b0e661e837..1411aa7183 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1451,38 +1451,6 @@ solaris*)
;;
esac
-dnl Look in /usr/local for header files and libraries ?
-dnl XXX FIXME don't include /usr/local if it is already in the system
-dnl search path as this causes gcc 3.2 on Linux to complain about a change
-dnl of the system search order for includes
-AC_ARG_ENABLE(usr-local,
- AC_HELP_STRING( [--enable-usr-local],
- [look for headers and libs in /usr/local tree @<:@default=yes@:>@]),
- ac_cv_enable_usr_local=$enableval,ac_cv_enable_usr_local=yes)
-
-AC_MSG_CHECKING(whether to use /usr/local for headers and libraries)
-if test "x$ac_cv_enable_usr_local" = "xyes" ; then
- if test -d "/usr/local"; then
- AC_MSG_RESULT(yes)
- #
- # Arrange that we search for header files in the source directory
- # and in its "wiretap" subdirectory, as well as in "/usr/local/include",
- # as various packages we use ("libpcap", "zlib", "c-ares")
- # may have been installed under "/usr/local/include".
- #
- AX_APPEND_FLAG([-I/usr/local/include], [WS_CPPFLAGS])
-
- #
- # Arrange that we search for libraries in "/usr/local/lib".
- #
- AC_WIRESHARK_ADD_DASH_L(WS_LDFLAGS, /usr/local/lib)
- else
- AC_MSG_RESULT(no)
- fi
-else
- AC_MSG_RESULT(no)
-fi
-
#
# If we're running Solaris, and LD_LIBRARY_PATH is defined, add it as a
# link directory.