summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2015-10-08 13:43:08 -0700
committerGuy Harris <guy@alum.mit.edu>2015-10-08 20:43:42 +0000
commit2bd7c48b44af5ebedefdb4c98d1b8cb708463881 (patch)
tree7e71ba7d89ec4c5ee88b2048e4566e9c101ee3ae /configure.ac
parentf274902be581b52db68c66f4864d85b7ea8fefe4 (diff)
downloadwireshark-2bd7c48b44af5ebedefdb4c98d1b8cb708463881.tar.gz
The second argument to AC_PATH_PROGS is a list of program names.
The *third* argument is the value to use if we don't find the program; we shouldn't fall back on "python3" if we can't find "python", we should try both "python" and "python3" and just set $PYTHON to nothing if we don't find either one. Change-Id: I5168455f09bc3165c49db4334f05856dec46bf62 Reviewed-on: https://code.wireshark.org/review/10890 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e708e0f8ba..f6d6945261 100644
--- a/configure.ac
+++ b/configure.ac
@@ -112,7 +112,7 @@ fi
AC_PATH_PROG(PERL, perl)
# Check for Python.
-AC_PATH_PROGS(PYTHON, python, python3)
+AC_PATH_PROGS(PYTHON, python python3)
if test ! -z "$PYTHON"; then
#
# OK, we found Python; is it Python 2.5 or later?