summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-02-10 09:11:12 +0000
committerJoão Valverde <j@v6e.pt>2016-02-19 15:55:09 +0000
commit8bee8bad813446bbf75428a8cdd756fe6063ca6f (patch)
treed6a335bcf1bf745c36fcefefab3356f6c1705a05 /configure.ac
parent5fec8fa74619a69e3faeca01fd483157d39f7b13 (diff)
downloadwireshark-8bee8bad813446bbf75428a8cdd756fe6063ca6f.tar.gz
Add inet_pton/inet_ntop interface to libwsutil
Change-Id: Ifc344ed33f2f7ca09a6912a5adb49dc35f07c81f Reviewed-on: https://code.wireshark.org/review/13881 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index e57727bdfd..759e7e52b3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2945,6 +2945,8 @@ have_inet_pton=no)
if test "$have_inet_pton" = no; then
INET_PTON_LO="inet_pton.lo"
else
+ AC_DEFINE(HAVE_INET_NTOP, 1,
+ [Define to 1 if you have the `inet_pton' function.])
INET_PTON_LO=""
fi
AM_CONDITIONAL(NEED_INET_PTON_LO, test "x$have_inet_pton" = "xno")
@@ -2974,9 +2976,7 @@ extern const char *inet_ntop(int, const void *, char *, socklen_t);],, [
[Define if inet_ntop() prototype exists])], [
AC_MSG_RESULT(no)])])
INET_NTOP_LO=""], [
- INET_NTOP_LO="inet_ntop.lo"
- AC_DEFINE(NEED_INET_V6DEFS_H, 1,
- [Define if inet/v6defs.h needs to be included])])
+ INET_NTOP_LO="inet_ntop.lo"])
AM_CONDITIONAL(NEED_INET_NTOP_LO, test "x$INET_NTOP_LO" != "x")
AC_SUBST(INET_NTOP_LO)