summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2016-09-26 10:34:04 -0700
committerGerald Combs <gerald@wireshark.org>2016-09-26 23:17:02 +0000
commitb725d6c9acc403dba30c72d20cf7103e4f490334 (patch)
tree90a8b5d226630b8ed14fb9d5a1a50104a254bf6a /configure.ac
parent06352a27b1ad2f9197b6193f97fad0c6947cc6d6 (diff)
downloadwireshark-b725d6c9acc403dba30c72d20cf7103e4f490334.tar.gz
Add an initial "shellcheck" target.
Look for shellcheck in Autotools and CMake, and if found add a target that checks some of our shell scripts. Add a "source=" directive to targets that include test-common.sh so that shellcheck will correctly process the scripts. Note that this requires shellcheck 0.4.0 or later. To do: Fix the issues that shellcheck found and check more scripts. Change-Id: I441f9f59d8a3f8eec6718119c2370f2560b98f3c Reviewed-on: https://code.wireshark.org/review/17943 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0f2c0fb01a..5487dd96a3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -544,6 +544,10 @@ AC_SUBST(HAVE_OSX_PACKAGING)
AC_CHECK_PROG(have_sw_vers, sw_vers, "yes", "no")
AM_CONDITIONAL(NOT_OS_X, test "x$have_sw_vers" = "xno")
+# Shellcheck
+AC_CHECK_PROG(HAVE_SHELLCHECK, shellcheck, "yes", "no")
+AM_CONDITIONAL(HAVE_SHELLCHECK, test x$HAVE_SHELLCHECK = xyes)
+
#
# Check compiler vendor. For GCC this will be 'gnu' and for Clang 'clang'.
#