summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-12-19 18:53:31 -0800
committerGuy Harris <guy@alum.mit.edu>2014-12-20 02:54:04 +0000
commitb73689649059060c5876a8ae281a2ded58a1b8fc (patch)
treea2b18d7154626619a3e597fd211c4e631c3414a2 /configure.ac
parent201a7e7d689bef213a0d303601c6ac41d02a21be (diff)
downloadwireshark-b73689649059060c5876a8ae281a2ded58a1b8fc.tar.gz
Handle floorl() the same way we handle other not-on-all-platforms functions.
Use AC_CHECK_FUNC() for it, define FLOORL_LO to floorl.lo if we *don't* have it, add FLOORL_LO to the list of items conditionally built in libwsutil, and include "wsutil/floor.h" only if HAVE_FLOORL is *not* defined, as that means it's *not* supplied by the platform and thus *not* declared in <math.h>. Also, use the standard export stuff in wsutil/floor.h. Change-Id: Ic24aa69f65f2d15450d8b84b0c2b0c58f38edebe Reviewed-on: https://code.wireshark.org/review/5901 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 73572c524b..b55f2221a4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2648,6 +2648,14 @@ AC_C_BIGENDIAN
# XXX - do we need this?
AC_PROG_GCC_TRADITIONAL
+AC_CHECK_FUNC(floorl,
+ [
+ FLOORL_LO=""
+ AC_DEFINE(HAVE_FLOORL, 1, [Define if you have the floorl function.])
+ ],
+ FLOORL_LO="floorl.lo")
+AC_SUBST(FLOORL_LO)
+
AC_CHECK_FUNC(getopt,
[
GETOPT_LO=""
@@ -2736,7 +2744,6 @@ AC_SUBST(STRPTIME_LO)
AC_CHECK_FUNCS(getprotobynumber gethostbyname2)
AC_CHECK_FUNCS(issetugid)
AC_CHECK_FUNCS(mmap mprotect sysconf)
-AC_CHECK_FUNCS(floorl)
dnl blank for now, but will be used in future
AC_SUBST(wireshark_SUBDIRS)