summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2015-11-18 17:28:45 +0000
committerAnders Broman <a.broman58@gmail.com>2015-11-19 08:02:37 +0000
commitc4a4b7c649840843063d012a4db91d6c69292b3f (patch)
treef551762f0e1c00d10b571746ee01dffb643a15f6 /configure.ac
parentc3ce6870fb83c171d1666800841716fcd6b25e80 (diff)
downloadwireshark-c4a4b7c649840843063d012a4db91d6c69292b3f.tar.gz
GResource configure.ac fixup
Use PKG_CHECK_EXISTS instead of PKG_CHECK_MODULE. Move check to happen after GLib. Change-Id: I29276fca12556ca69cdf521a1ca22659dec28408 Reviewed-on: https://code.wireshark.org/review/11949 Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com> Petri-Dish: Alexis La Goutte <alexis.lagoutte@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 49111ad23e..4bd21bf75e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1788,13 +1788,6 @@ AC_SUBST(GLIB_MIN_VERSION)
# 2.44.0: 23 Mar 2014
# 2.46.0: 25 Sep 2015
-# Check for GResource support
-PKG_CHECK_MODULES([GRESOURCE], [gio-2.0 >= 2.32 gdk-pixbuf-2.0 >= 2.26], [have_gresource=yes], [have_gresource=no])
-AM_CONDITIONAL(HAVE_GRESOURCE, test "x$have_gresource" = "xyes")
-if test "x$have_gresource" = "xyes"; then
- AC_DEFINE(HAVE_GRESOURCE, 1, [Defined if GLib GResource is supported])
-fi
-
use_glib_cflags="true"
if test "$have_gtk" = "yes" -a "$have_qt" = "yes" ; then
# We have both GTK and Qt and thus will be building both wireshark
@@ -1873,6 +1866,13 @@ else
AM_PATH_GLIB_2_0($GLIB_MIN_VERSION, , AC_MSG_ERROR(GLib $GLIB_MIN_VERSION or later distribution not found.), gthread gmodule)
fi
+# Check for GResource support
+PKG_CHECK_EXISTS([gio-2.0 >= 2.32 gdk-pixbuf-2.0 >= 2.26], [have_gresource=yes], [have_gresource=no])
+AM_CONDITIONAL(HAVE_GRESOURCE, test "x$have_gresource" = "xyes")
+if test "x$have_gresource" = "xyes"; then
+ AC_DEFINE(HAVE_GRESOURCE, 1, [Defined if GLib GResource is supported])
+fi
+
# Error out if a glib header other than a "top level" header
# (glib.h, glib-object.h, gio.h) or certain other headers( e.g.,gmodule.h)
# is used.