summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2016-12-02 11:36:45 -0800
committerPeter Wu <peter@lekensteyn.nl>2016-12-06 17:24:00 +0000
commitd8cdb550445a1bc86626bd9d45da1ce958d1592b (patch)
tree29c19cf49c6b63b3bbdf85306005d0cb3e057e97 /configure.ac
parentc33429765473dc1e7e46a24305bbf921685401e3 (diff)
downloadwireshark-d8cdb550445a1bc86626bd9d45da1ce958d1592b.tar.gz
Autotools: Disable Qt4 on macOS.
Add a check for macOS+Qt4 to configure.ac in order to roughly match the CMake behavior in ge858829. Change-Id: I37de95d5db515d28dd88f13d818531bf6e94d07e Reviewed-on: https://code.wireshark.org/review/19036 Reviewed-by: Gerald Combs <gerald@wireshark.org> Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Peter Wu <peter@lekensteyn.nl>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 8 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 1ba2415153..d39c3746d6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1293,18 +1293,19 @@ if test "x$enable_wireshark" = "xyes"; then
AC_SUBST(LRELEASE)
#
- # On Darwin, find where the Qt frameworks are
- # located, and add that to the rpath, just in
- # case this is Qt 5.5 or later and the frameworks
- # have an install name that begins with @rpath
- # and aren't installed in a frameworks directory
- # that's searched by default.
+ # On Darwin, make sure we're using Qt5 or later.
+ # If so, find where the Qt frameworks are located
+ # and add that to the rpath, just in case this is
+ # Qt 5.5 or later and the frameworks have an
+ # install name that begins with @rpath and aren't
+ # installed in a frameworks directory that's
+ # searched by default.
#
case "$host_os" in
darwin*)
if test $qt_version -le 4
then
- Qt_LDFLAGS="-Wl,-rpath,"`$PKG_CONFIG --libs QtCore | sed -e 's/-F//' -e 's/ -framework.*//'`
+ AC_MSG_ERROR([macOS builds should use Qt5])
else
Qt_LDFLAGS="-Wl,-rpath,"`$PKG_CONFIG --libs Qt${qt_version}Core | sed -e 's/-F//' -e 's/ -framework.*//'`
fi