summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-03-26 03:16:17 +0000
committerAnders Broman <a.broman58@gmail.com>2016-04-04 06:49:55 +0000
commite005bc819c201c49cf330a2607ad0770f145904e (patch)
treeaaff654c2682c3bde08440b5d9526deee1e033c5 /configure.ac
parent1cf7834b2d16f549c6145e5d36b8b7dd7a384223 (diff)
downloadwireshark-e005bc819c201c49cf330a2607ad0770f145904e.tar.gz
Remove synchronous DNS name resolution
Change-Id: Ie5e670b769eb0674950f3679ef511047641c2873 Reviewed-on: https://code.wireshark.org/review/14751 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 3 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 4217f29ec6..b83db53280 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2628,9 +2628,6 @@ else
fi
AC_SUBST(C_ARES_LIBS)
-# Check for synchronous name resolvers
-AC_CHECK_FUNCS([getaddrinfo gethostbyname gethostbyname2])
-
dnl GEOIP Check
GEOIP_LIBS=''
AC_MSG_CHECKING(whether to use the GeoIP IP address mapping library if available)
@@ -2715,6 +2712,8 @@ AC_C_BIGENDIAN
# XXX - do we need this?
AC_PROG_GCC_TRADITIONAL
+AC_CHECK_FUNCS([getaddrinfo])
+
AC_CHECK_FUNC(getopt_long,
[
GETOPT_LO=""
@@ -3354,8 +3353,7 @@ fi
if test "x$have_good_c_ares" = "xyes" ; then
c_ares_message="yes"
else
- # We should make this an error at some point.
- c_ares_message="no. This can cause serious performance issues."
+ c_ares_message="no (name resolution will be disabled)"
fi
if test "x$have_good_libcap" = "xyes" ; then