summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-04-04 02:25:01 +0100
committerJoão Valverde <j@v6e.pt>2016-04-09 23:40:51 +0000
commited6eecd79e7b933bccc442589ed3689a646c1256 (patch)
tree3bc759a68ea34eb322c4e78679f9a72f84f7fc91 /configure.ac
parent320726b83e2096d9431f28208437a738b31d8ad9 (diff)
downloadwireshark-ed6eecd79e7b933bccc442589ed3689a646c1256.tar.gz
[GTK] Check for xdg-open at run time
Remove HTML_VIEWER compile-time setting. If xdg-open doesn't exist use user web browser preference as fallback. Change-Id: I3b4a4a1a36b0192d75f2c97595f37d0d88a0941e Reviewed-on: https://code.wireshark.org/review/14805 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Peter Wu <peter@lekensteyn.nl> Tested-by: Peter Wu <peter@lekensteyn.nl> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 0 insertions, 35 deletions
diff --git a/configure.ac b/configure.ac
index 50f6c85ff8..3283953fcf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -190,41 +190,6 @@ then
fi
#
-# Checks for programs used by Wireshark/TShark/etc.
-#
-
-#
-# XXX - this looks for various HTML viewers on the host, not the target;
-# we really want to know what's available on the target, for cross-builds.
-# That would probably require us to, at run time, look for xdg-open and,
-# if we don't find it, look for mozilla, htmlview, etc.
-#
-AC_PATH_PROG(HTML_VIEWER, xdg-open)
-if test "x$HTML_VIEWER" != x
-then
- #
- # XXX - the HTML_VIEWER shell variable is the full path of xdg-open.
- # Define some variable to be that, so we just run that?
- #
- AC_DEFINE(HAVE_XDG_OPEN, 1, [Define if we have xdg-open])
-
- #
- # XXX - we have to define HTML_VIEWER for the prefs.c code that
- # sets the default value of the Web browser preference, even
- # though that preference won't be offered.
- #
- AC_DEFINE_UNQUOTED(HTML_VIEWER, "xdg-open", [HTML viewer, e.g. mozilla])
-else
- AC_PATH_PROG(HTML_VIEWER, htmlview)
- if test "x$HTML_VIEWER" = x
- then
- AC_DEFINE_UNQUOTED(HTML_VIEWER, "mozilla", [HTML viewer, e.g. mozilla])
- else
- AC_DEFINE_UNQUOTED(HTML_VIEWER, "htmlview", [HTML viewer, e.g. mozilla])
- fi
-fi
-
-#
# Set "ac_supports_gcc_flags" if the compiler is known to support GCC-style
# flags such as -pedantic, -W warning flags and -f feature flags. Currently,
# we assume GCC and clang do; other compilers should be added here.