summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2007-11-21 18:32:44 +0000
committerGerald Combs <gerald@wireshark.org>2007-11-21 18:32:44 +0000
commit4e70cac80c25fee1769d7d44083d97f9201bbd3f (patch)
treeb207e7f3e5855ba9d30ef0036f8cfbc751cac686 /configure.in
parentf3fdef83d67e9ad6d263065ebee80290847e1359 (diff)
downloadwireshark-4e70cac80c25fee1769d7d44083d97f9201bbd3f.tar.gz
Make it easier to change the default behavior of --enable-warnings-as-errors.
svn path=/trunk/; revision=23531
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index b043fdd584..74dd3be545 100644
--- a/configure.in
+++ b/configure.in
@@ -226,6 +226,7 @@ fi
# This barrier is set for a very large part of the code. However, it is
# typically not set for "generated" code (lex, ans2wrs, idl2wrs, ...)
#
+$warnings_as_errors_default="yes"
AC_MSG_CHECKING(whether we should treat compiler warnings as errors)
AC_ARG_ENABLE(warnings-as-errors,
AC_HELP_STRING( [--enable-warnings-as-errors],
@@ -239,7 +240,7 @@ AC_ARG_ENABLE(warnings-as-errors,
AC_MSG_RESULT(no)
fi
],
- if test "x$GCC" = "xyes" -a "x$wireshark_extra_gcc_flags" = "x"; then
+ if test "x$GCC" = "xyes" -a "x$wireshark_extra_gcc_flags" = "x" -a "x$warnings_as_errors_default" = "xyes"; then
with_warnings_as_errors="yes"
AC_MSG_RESULT(yes)
else