summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2004-07-21 17:45:05 +0000
committerJörg Mayer <jmayer@loplof.de>2004-07-21 17:45:05 +0000
commit6ecefef982aaa6be471116d8f4b56f54fb65f3b5 (patch)
treef8e80e8d826e4a138eb93924d541782fb478d3c3 /configure.in
parentdcea6b49c6749f6a0027031db01c4fc8809c576b (diff)
downloadwireshark-6ecefef982aaa6be471116d8f4b56f54fb65f3b5.tar.gz
Forgotten case: Make krb5 fail if it requires -lcrypto but no --with-ssl=... is not given
svn path=/trunk/; revision=11458
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 408fb1be13..5e869c5e55 100644
--- a/configure.in
+++ b/configure.in
@@ -739,6 +739,7 @@ if test "x$enable_ssl" = "xno" ; then
AC_MSG_RESULT(no)
else
AC_MSG_RESULT(yes)
+ AC_MSG_CHECKING(whether SSL library is available)
AC_ETHEREAL_SSL_CHECK
fi
AC_SUBST(SSL_LIBS)
@@ -816,7 +817,7 @@ if test "x$NETSNMPCONFIG" != "xno" -a "x$NETSNMPCONFIG" != "x" -a -x "$NETSNMPCO
AC_CHECK_HEADERS(net-snmp/net-snmp-config.h net-snmp/library/default_store.h)
if test "x$ac_cv_header_net_snmp_net_snmp_config_h" = "xyes" -a "x$ac_cv_header_net_snmp_library_default_store_h" = "xyes" ; then
SNMP_LIBS=`$NETSNMPCONFIG --libs`
- if echo "$SNMP_LIBS" | grep crypto && test "x$SSL_LIBS" = "x"; then
+ if echo "$SNMP_LIBS" | grep crypto >/dev/null && test "x$SSL_LIBS" = "x"; then
AC_MSG_RESULT(Net-SNMP requires openssl but ssl not enabled - disabling Net-SNMP)
CFLAGS="$ethereal_save_CFLAGS"
CPPFLAGS="$ethereal_save_CPPFLAGS"