summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAnders Broman <anders.broman@ericsson.com>2006-08-30 21:51:31 +0000
committerAnders Broman <anders.broman@ericsson.com>2006-08-30 21:51:31 +0000
commit7eac3c28796d480b79da5b59dc59115d717a61ef (patch)
treec77a14f5d9fd078b6c27806c9c116ed51eb257d7 /configure.in
parent55ddc3dd59102d8ebc30acb9af7bc5c395bcdc1b (diff)
downloadwireshark-7eac3c28796d480b79da5b59dc59115d717a61ef.tar.gz
From Alejandro Vaquero:
- Change the "listen_rtp" to "rtp_player" - Change from a plugin to be part of the core - By default it will not compile with the rtp_player. In order to compile it is necessary to: + For windows: uncomment the line "PORTAUDIO_DIR=$(WIRESHARK_LIBS)\portaudio_v18_1" in config.nmake + For linux: using the "--with-portaudio=yes" svn path=/trunk/; revision=19094
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in43
1 files changed, 43 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index adf506c856..de8db71929 100644
--- a/configure.in
+++ b/configure.in
@@ -821,6 +821,41 @@ fi
AM_CONDITIONAL(HAVE_LIBLUA, test x$want_lua = xyes)
+dnl portaudio check
+AC_MSG_CHECKING(whether to use libportaudio for the rtp_player)
+
+AC_ARG_WITH(portaudio,
+[ --with-portaudio[[=DIR]] use libportaudio (located in directory DIR, if supplied) for the rtp_player. [[default=no]]],
+[
+ if test $withval = no
+ then
+ want_portaudio=no
+ elif test $withval = yes
+ then
+ want_portaudio=yes
+ else
+ want_portaudio=yes
+ portaudio_dir=$withval
+ fi
+],[
+ #
+ # Don't use libportaudio by default
+ #
+ want_portaudio=no
+ portaudio_dir=
+])
+if test "x$want_portaudio" = "xno" ; then
+ AC_MSG_RESULT(no)
+else
+ AC_MSG_RESULT(yes)
+ AC_WIRESHARK_LIBPORTAUDIO_CHECK
+ if test "x$want_portaudio" = "xno" ; then
+ AC_MSG_RESULT(libportaudio not found - disabling support for the rtp_player)
+ fi
+fi
+AM_CONDITIONAL(HAVE_LIBPORTAUDIO, test x$want_portaudio = xyes)
+
+
dnl ipv6 check
AC_ARG_ENABLE(ipv6,
[ --enable-ipv6 use ipv6 name resolution, if available. [default=yes]],enable_ipv6=$enableval,enable_ipv6=yes)
@@ -1313,6 +1348,7 @@ AC_OUTPUT(
epan/dissectors/Makefile
epan/ftypes/Makefile
gtk/Makefile
+ gtk/codecs/Makefile
gtk/doxygen.cfg
help/Makefile
packaging/Makefile
@@ -1381,6 +1417,12 @@ else
lua_message="no"
fi
+if test "x$want_portaudio" = "xyes" ; then
+ portaudio_message="yes"
+else
+ portaudio_message="no"
+fi
+
if test "x$want_ssl" = "xno" ; then
ssl_message="no"
else
@@ -1423,6 +1465,7 @@ echo ""
echo " Install setuid : $setuid_message"
echo " Use plugins : $have_plugins"
echo " Build lua plugin : $lua_message"
+echo " Build rtp_player : $portaudio_message"
echo " Use GTK+ v2 library : $enable_gtk2"
if test "x$enable_gtk2" = "xyes" ; then
echo " Use threads : $enable_threads"