summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMichael Tüxen <tuexen@fh-muenster.de>2009-09-02 19:16:59 +0000
committerMichael Tüxen <tuexen@fh-muenster.de>2009-09-02 19:16:59 +0000
commit86cf763175a363b5bc0c89a5e74f3f050c74e0da (patch)
tree1059c734c23b8b00a1b3be52593ae78730464a32 /configure.in
parent283a4997ba7566f7b2667e637b52a98b1a55760c (diff)
downloadwireshark-86cf763175a363b5bc0c89a5e74f3f050c74e0da.tar.gz
Add --enable-new-packet-list to configure script. Default
is no for now. Should be kept in sync with the corresponding Windows switch. svn path=/trunk/; revision=29676
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 47a713b0cd..0fc8e7e88d 100644
--- a/configure.in
+++ b/configure.in
@@ -1613,6 +1613,18 @@ then
fi
AC_SUBST(ENABLE_STATIC)
+AC_ARG_ENABLE(new-packet-list,
+ AC_HELP_STRING( [--enable-new-packet-list],
+ [use new packet list feature. @<:@default=no@:>@]),
+ new_packet_list=$enableval,new_packet_list=no)
+AC_MSG_CHECKING(if new packet list is used);
+if test "x$enable_new_packet_list" = "xyes" ; then
+ AC_MSG_RESULT(yes)
+ CFLAGS=" -DNEW_PACKET_LIST $CFLAGS"
+else
+ AC_MSG_RESULT(no)
+fi
+
dnl Save the cacheable configure results to config.cache before recursing
AC_CACHE_SAVE