summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorStig Bjørlykke <stig@bjorlykke.org>2009-10-06 16:01:18 +0000
committerStig Bjørlykke <stig@bjorlykke.org>2009-10-06 16:01:18 +0000
commit98024a007f590ed79ce43b89bcf7287ea240b989 (patch)
tree0dc184c467bbca781c4d7a049ab14a67b4e5cfea /configure.in
parentc88f493d4d1d07933339ffe17d33a0ccfcc8cc32 (diff)
downloadwireshark-98024a007f590ed79ce43b89bcf7287ea240b989.tar.gz
Invert check for getopt: NEED_GETOPT_H -> HAVE_GETOPT_H
Rename getopt.[ch] -> wsgetopt.[ch] to avoid name collision. svn path=/trunk/; revision=30370
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 8 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index c7c1f6c90a..5ec0a1dbad 100644
--- a/configure.in
+++ b/configure.in
@@ -1421,13 +1421,15 @@ AC_PROG_GCC_TRADITIONAL
GETOPT_C=""
GETOPT_O=""
-AC_CHECK_FUNC(getopt, GETOPT_O="",
- [GETOPT_O="getopt.o"
- AC_DEFINE(NEED_GETOPT_H, 1, [Define if getopt.h needs to be included])
-])
+AC_CHECK_FUNC(getopt,
+ [GETOPT_O=""
+ AC_DEFINE(HAVE_GETOPT_H, 1, [Define to 1 if you have the <getopt.h> header file.])
+ ],
+ GETOPT_O="wsgetopt.o"
+)
if test "$ac_cv_func_getopt" = no ; then
- GETOPT_C="getopt.c"
- GETOPT_O="getopt.o"
+ GETOPT_C="wsgetopt.c"
+ GETOPT_O="wsgetopt.o"
fi
AC_SUBST(GETOPT_C)
AC_SUBST(GETOPT_O)