summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2004-03-17 18:20:58 +0000
committerJörg Mayer <jmayer@loplof.de>2004-03-17 18:20:58 +0000
commit9920ca911230473e90a785e6f83ac4ed74c25d8f (patch)
tree5cfc37fcd743e91f9b41d09d6b272dad3d8c97e3 /configure.in
parent0e4e864b488943d4c423bac6e790db91c01d38c9 (diff)
downloadwireshark-9920ca911230473e90a785e6f83ac4ed74c25d8f.tar.gz
Experimental Heimdal Kerberos detection.
As this is experimental and does not yet work reliably this feature is off by default. Enable it by using --with-krb5 during configure. Please do not yet make use of this feature (i.e. please do not *use* the defines provided by this option), until it has received further testing and fixing. Please run and check what the configure says. svn path=/trunk/; revision=10395
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in46
1 files changed, 45 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index b39c13dd3a..47154905bd 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.250 2004/03/04 06:28:42 guy Exp $
+# $Id: configure.in,v 1.251 2004/03/17 18:20:57 jmayer Exp $
#
AC_INIT(etypes.h)
@@ -701,6 +701,43 @@ fi
AC_SUBST(SNMP_LIBS)
+
+dnl kerberos/heimdal check
+AC_MSG_CHECKING(whether to use kerberos/heimdal)
+
+AC_ARG_WITH(krb5,
+changequote(<<, >>)dnl
+<< --with-krb5[=DIR] use kerberos/heimdal (located in directory DIR, if supplied) to use in kerberos dissection [default=no]>>,
+changequote([, ])dnl
+[
+ if test $withval = no
+ then
+ want_krb5=no
+ elif test $withval = yes
+ then
+ want_krb5=yes
+ else
+ want_krb5=no
+ krb5_dir=$withval
+ fi
+],[
+ #
+ # Use kerberos/heimdal if it's present, otherwise don't.
+ #
+ want_krb5=no
+ krb5_dir=
+])
+if test "x$want_krb5" = "xno" ; then
+ AC_MSG_RESULT(no)
+else
+ AC_MSG_RESULT(yes)
+ AC_ETHEREAL_KRB5_CHECK
+ if test "x$want_krb5" = "xno" ; then
+ AC_MSG_RESULT(heimdal not found - disabling dissection for some kerberos data in packet decoding)
+ fi
+fi
+
+
dnl ADNS Check
ADNS_LIBS=''
AC_MSG_CHECKING(whether to use the GNU ADNS library if available)
@@ -916,6 +953,12 @@ else
pcre_message="yes"
fi
+if test "x$want_krb5" = "xno" ; then
+ krb5_message="no"
+else
+ krb5_message="yes (heimdal)"
+fi
+
if test "x$have_good_adns" = "xyes" ; then
adns_message="yes"
else
@@ -951,6 +994,7 @@ fi
echo " Use pcap library : $want_pcap"
echo " Use zlib library : $zlib_message"
echo " Use pcre library : $pcre_message"
+echo " Use kerberos library : $krb5_message"
echo " Use GNU ADNS library : $adns_message"
echo " Use IPv6 name resolution : $enable_ipv6"
echo " Use UCD SNMP/NET-SNMP library : $snmp_libs_message"