summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorBalint Reczey <balint@balintreczey.hu>2014-06-05 17:30:41 +0700
committerBalint Reczey <balint@balintreczey.hu>2014-06-08 15:32:10 +0000
commit97e1491aa8f418a7f5bd7fdd92561d2403c187f6 (patch)
treeeadecb1b66ac3900a7e5db76eb2b993693ba0b9f /debian/patches
parent9b4991098f42bfe10da9ce34c4c7711fbcf87ca7 (diff)
downloadwireshark-97e1491aa8f418a7f5bd7fdd92561d2403c187f6.tar.gz
Sync .deb packaging from Debian
The sync makes CMake the build system for the .deb package and starts providing wireshark-qt in the wireshark-qt package. The package structure, i.e. the libraries are shipped in separate packages is also sync-ed. Wireshark-qt uses the Qt 4 libraries, but it is easy to switch it to Qt 5. Change-Id: I849d18bdb8ca6ebf4072cf1d73d749080ac5dac2 Reviewed-on: https://code.wireshark.org/review/1986 Reviewed-by: Gerald Combs <gerald@wireshark.org> Reviewed-by: Balint Reczey <balint@balintreczey.hu> Tested-by: Balint Reczey <balint@balintreczey.hu>
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/0005-Disable-xmllint-for-release-notes.patch40
-rw-r--r--debian/patches/00list12
-rw-r--r--debian/patches/01_Disable-building-documentation-in-PDF-and-release-no.patch48
-rw-r--r--debian/patches/04_asn2wrs_ply.patch17
-rw-r--r--debian/patches/05_note-README-when-running-as-root.patch15
-rw-r--r--debian/patches/06_release-version.patch15
-rwxr-xr-xdebian/patches/08_wireshark-desktop-menu.patch13
-rwxr-xr-xdebian/patches/09_idl2wrs.patch48
-rw-r--r--debian/patches/16_licence_about_location.patch14
-rw-r--r--debian/patches/series8
10 files changed, 218 insertions, 12 deletions
diff --git a/debian/patches/0005-Disable-xmllint-for-release-notes.patch b/debian/patches/0005-Disable-xmllint-for-release-notes.patch
new file mode 100644
index 0000000000..df874aab67
--- /dev/null
+++ b/debian/patches/0005-Disable-xmllint-for-release-notes.patch
@@ -0,0 +1,40 @@
+From a687b01c0796f9b8a883626a654f31a45a3137ab Mon Sep 17 00:00:00 2001
+From: Balint Reczey <balint@balintreczey.hu>
+Date: Thu, 29 May 2014 23:22:12 +0700
+Subject: [PATCH] Disable xmllint for release-notes
+
+Change-Id: I1148341710f064e1d92e2b0eb60708c4af528f1b
+---
+ cmake/modules/FindASCIIDOC.cmake | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/cmake/modules/FindASCIIDOC.cmake b/cmake/modules/FindASCIIDOC.cmake
+index f414c54..175f2dd 100644
+--- a/cmake/modules/FindASCIIDOC.cmake
++++ b/cmake/modules/FindASCIIDOC.cmake
+@@ -38,6 +38,7 @@ MACRO( ASCIIDOC2HTML _output _asciidocsource _conffile )
+ --destination-dir=${CMAKE_CURRENT_BINARY_DIR}
+ --asciidoc-opts="--conf-file=${CMAKE_CURRENT_SOURCE_DIR}/${_conffile}"
+ --fop
++ --no-xmllint
+ ${A2X_HTML_OPTS}
+ ${_asciidocsource}
+ # Replacing file with itself will fail
+@@ -66,6 +67,7 @@ MACRO( ASCIIDOC2TXT _output _asciidocsource _conffile )
+ --destination-dir=${CMAKE_CURRENT_BINARY_DIR}
+ --asciidoc-opts="--conf-file=${CMAKE_CURRENT_SOURCE_DIR}/${_conffile}"
+ --fop
++ --no-xmllint
+ ${A2X_TEXT_OPTS}
+ --xsltproc-opts '--stringparam generate.toc "article nop"'
+ ${_asciidocsource}
+@@ -93,6 +95,7 @@ MACRO( ASCIIDOC2PDF _output _asciidocsource _conffile _paper )
+ --destination-dir=${CMAKE_CURRENT_BINARY_DIR}
+ --asciidoc-opts="--conf-file=${CMAKE_CURRENT_SOURCE_DIR}/${_conffile}"
+ --fop
++ --no-xmllint
+ ${A2X_HTML_OPTS}
+ --xsltproc-opts "--stringparam paper.type ${_paper} --nonet"
+ --xsl-file=custom_layer_pdf.xsl
+--
+1.9.1
diff --git a/debian/patches/00list b/debian/patches/00list
deleted file mode 100644
index 64fbf26eb4..0000000000
--- a/debian/patches/00list
+++ /dev/null
@@ -1,12 +0,0 @@
-#03_preferences
-#04_drop-capabilities
-#05_plugin-libdir
-#06_giop-buffer
-#07_gcc4
-#08_wireshark-desktop-menu
-#09_idl2wrs
-#10_wireshark_gen
-#14_disable-cmip
-#15_sensitive_open
-#16_licence_about_location
-#17_clique_rm_support
diff --git a/debian/patches/01_Disable-building-documentation-in-PDF-and-release-no.patch b/debian/patches/01_Disable-building-documentation-in-PDF-and-release-no.patch
new file mode 100644
index 0000000000..5702f250b9
--- /dev/null
+++ b/debian/patches/01_Disable-building-documentation-in-PDF-and-release-no.patch
@@ -0,0 +1,48 @@
+From 2c646fef768917a94e2147aab2eff45899a0f9b3 Mon Sep 17 00:00:00 2001
+From: Balint Reczey <balint@balintreczey.hu>
+Date: Fri, 30 May 2014 09:30:15 +0700
+Subject: [PATCH] Disable building documentation in PDF and release notes in
+ HTML
+
+Change-Id: I86b3bae00d9e08fbe5c5e04ccc3db8f4e4734dbf
+---
+ docbook/CMakeLists.txt | 14 +++++++-------
+ 1 file changed, 7 insertions(+), 7 deletions(-)
+
+--- a/docbook/CMakeLists.txt
++++ b/docbook/CMakeLists.txt
+@@ -332,8 +332,8 @@
+ wsluarm
+ wsug_html_chunked/index.html
+ wsug_html/index.html
+- user-guide-a4.pdf
+- user-guide-us.pdf
++# user-guide-a4.pdf
++# user-guide-us.pdf
+ )
+
+ VALIDATE_XML(
+@@ -381,8 +381,8 @@
+ wsluarm
+ wsdg_html_chunked/index.html
+ wsdg_html/index.html
+- developer-guide-a4.pdf
+- developer-guide-us.pdf
++# developer-guide-a4.pdf
++# developer-guide-us.pdf
+ )
+
+ VALIDATE_XML(
+@@ -425,10 +425,10 @@
+ add_custom_target(
+ release_notes ALL
+ DEPENDS
+- release-notes.html
++# release-notes.html
+ release-notes.txt
+- release-notes-a4.pdf
+- release-notes-us.pdf
++# release-notes-a4.pdf
++# release-notes-us.pdf
+ ${CMAKE_SOURCE_DIR}/NEWS
+ )
diff --git a/debian/patches/04_asn2wrs_ply.patch b/debian/patches/04_asn2wrs_ply.patch
new file mode 100644
index 0000000000..2cf2bae9c9
--- /dev/null
+++ b/debian/patches/04_asn2wrs_ply.patch
@@ -0,0 +1,17 @@
+Description: Use lex/yacc from ply
+Forwarded: not-needed
+Bug-Debian: http://bugs.debian.org/554613
+Author: Jakub Wilk <ubanus@users.sf.net>
+
+--- a/tools/asn2wrs.py
++++ b/tools/asn2wrs.py
+@@ -70,8 +70,8 @@
+ import getopt
+ import traceback
+
+-import lex
+-import yacc
++from ply import lex
++from ply import yacc
+
+ from functools import partial
diff --git a/debian/patches/05_note-README-when-running-as-root.patch b/debian/patches/05_note-README-when-running-as-root.patch
new file mode 100644
index 0000000000..7c3c63f97b
--- /dev/null
+++ b/debian/patches/05_note-README-when-running-as-root.patch
@@ -0,0 +1,15 @@
+Description: Note about README.Debian when running wireshark as root.
+Forwarded: not-needed
+Author: Balint Reczey <balint@balintreczey.hu>
+
+--- a/ui/gtk/main.c
++++ b/ui/gtk/main.c
+@@ -2085,7 +2085,7 @@
+ "This could be dangerous.\n\n"
+ "If you're running Wireshark this way in order to perform live capture, "
+ "you may want to be aware that there is a better way documented at\n"
+- "http://wiki.wireshark.org/CaptureSetup/CapturePrivileges", cur_user, cur_group);
++ "/usr/share/doc/wireshark-common/README.Debian", cur_user, cur_group);
+ g_free(cur_user);
+ g_free(cur_group);
+ simple_dialog_check_set(priv_warning_dialog, "Don't show this message again.");
diff --git a/debian/patches/06_release-version.patch b/debian/patches/06_release-version.patch
new file mode 100644
index 0000000000..ee5584fd59
--- /dev/null
+++ b/debian/patches/06_release-version.patch
@@ -0,0 +1,15 @@
+Description: Don't regenerate svnversion.h
+Forwarded: not-needed
+Author: Balint Reczey <balint@balintreczey.hu>
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -638,7 +638,7 @@
+ am__v_PERL_0 = @echo " PERL " $@;
+ am__v_PERL_1 =
+
+-version.h: FORCE
++version.h:
+ $(AM_V_PERL)$(PERL) $(srcdir)/make-version.pl $(srcdir)
+
+ #
diff --git a/debian/patches/08_wireshark-desktop-menu.patch b/debian/patches/08_wireshark-desktop-menu.patch
new file mode 100755
index 0000000000..21e0980969
--- /dev/null
+++ b/debian/patches/08_wireshark-desktop-menu.patch
@@ -0,0 +1,13 @@
+Description: Change Icon and Categories for desktop file
+Forwarded: not-needed
+Author: <fred@candle>
+
+--- a/wireshark.desktop
++++ b/wireshark.desktop
+@@ -75,4 +75,5 @@
+ MimeType=application/vnd.tcpdump.pcap;application/x-pcapng;application/x-snoop;application/x-iptrace;application/x-lanalyzer;application/x-nettl;application/x-radcom;application/x-etherpeek;application/x-visualnetworks;application/x-netinstobserver;application/x-5view;
+ # Category entry according to:
+ # http://standards.freedesktop.org/menu-spec/1.0/
+-Categories=System;Monitor;GTK;
++Categories=GNOME;Network;
++Encoding=UTF-8
diff --git a/debian/patches/09_idl2wrs.patch b/debian/patches/09_idl2wrs.patch
new file mode 100755
index 0000000000..f479ba650d
--- /dev/null
+++ b/debian/patches/09_idl2wrs.patch
@@ -0,0 +1,48 @@
+Description: Do not try to locate wireshark_be.py and wireshark_gen.py in
+ non-standard places.
+Author: Frederic Peters <fpeters@debian.org>
+
+--- a/tools/idl2wrs
++++ b/tools/idl2wrs
+@@ -65,41 +65,8 @@
+ exit 1;
+ fi
+
+-#
+-# Run wireshark backend, looking for wireshark_be.py and wireshark_gen.py
+-# in pythons's "site-packages" directory. If cannot find that, then
+-# try looking in current directory. If still cannot, then exit with
+-# error.
+-
+-if [ -f $PYTHONPATH/site-packages/wireshark_be.py ] && [ -f $PYTHONPATH/site-packages/wireshark_gen.py ]; then
+- exec omniidl -p $PYTHONPATH/site-packages -b wireshark_be $@
+- /* not reached */
+-fi
+-
+-# Try current directory.
+-
+-if [ -f ./wireshark_be.py ] && [ -f ./wireshark_gen.py ]; then
+- exec omniidl -p ./ -b wireshark_be $@
+- /* not reached */
+-fi
+-
+-# Could not find both wireshark_be.py AND wireshark_gen.py
+-# So let's just try to run it without -p, hoping that the installation
+-# set up a valid path.
+-
+ exec omniidl -b wireshark_be $@
+
+-old code: not reached
+-
+-echo "idl2wrs Error: Could not find both wireshark_be.py AND wireshark_gen.py."
+-echo "Please ensure you have the PYTHONPATH variable set, or that wireshark_be.py "
+-echo "and wireshark_gen.py exist in the current directory. "
+-echo
+-echo "On this system, PYTHONPATH is : $PYTHONPATH"
+-echo
+-
+-exit 2
+-
+
+ #
+ # Editor modelines - http://www.wireshark.org/tools/modelines.html
diff --git a/debian/patches/16_licence_about_location.patch b/debian/patches/16_licence_about_location.patch
new file mode 100644
index 0000000000..36cebffc18
--- /dev/null
+++ b/debian/patches/16_licence_about_location.patch
@@ -0,0 +1,14 @@
+Description: Change location of license file in about dialog
+Forwarded: not-needed
+Author: Frederic Peters <fpeters@debian.org>
+
+--- a/ui/gtk/about_dlg.c
++++ b/ui/gtk/about_dlg.c
+@@ -506,7 +506,7 @@
+ #if defined(_WIN32)
+ absolute_path = get_datafile_path("COPYING.txt");
+ #else
+- absolute_path = get_datafile_path("COPYING");
++ absolute_path = get_datafile_path("ABOUT.GPL");
+ #endif
+ page = text_page_new(absolute_path);
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000000..5a7314e2a9
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,8 @@
+0005-Disable-xmllint-for-release-notes.patch
+01_Disable-building-documentation-in-PDF-and-release-no.patch
+04_asn2wrs_ply.patch
+05_note-README-when-running-as-root.patch
+06_release-version.patch
+08_wireshark-desktop-menu.patch
+09_idl2wrs.patch
+16_licence_about_location.patch