summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJaap Keuter <jaap.keuter@xs4all.nl>2008-05-31 16:44:02 +0000
committerJaap Keuter <jaap.keuter@xs4all.nl>2008-05-31 16:44:02 +0000
commit9323e90cc525f8acd2b35254f5e90bce9dd96b83 (patch)
treeca7b9be16043104bf492eddd25561e444597784b /debian/rules
parentfa2b419e608f752c5051f62d84ec7e5cdffb1436 (diff)
downloadwireshark-9323e90cc525f8acd2b35254f5e90bce9dd96b83.tar.gz
Update Debian packaging files for Wireshark 1.0.
These files build the package with all features and minimum changes from the released sources. svn path=/trunk/; revision=25406
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules91
1 files changed, 43 insertions, 48 deletions
diff --git a/debian/rules b/debian/rules
index 1169776c11..d0e6b4f7f6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,21 +13,16 @@ DB2MAN=/usr/share/xml/docbook/stylesheet/nwalsh/manpages/docbook.xsl
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-PYTHON_VERSION=python2.3
+PYTHON_VERSION=python2.4
+
+CFLAGS=-g -O2
# Enable IEEE-conformant floating point math on alphas (not the default)
ifeq (alpha-linux,$(DEB_HOST_GNU_TYPE))
CFLAGS += -mieee
endif
-idl2deb.1: idl2deb.dbk
- xsltproc --nonet --novalid $(DB2MAN) $<
-
-asn2deb.1: asn2deb.dbk
- xsltproc --nonet --novalid $(DB2MAN) $<
-
-
-CONFIGURE_FLAGS=--prefix=/usr --sysconfdir=/usr/share/wireshark --datadir=/usr/share/wireshark --disable-static --disable-ssl --without-ucdsnmp --enable-gtk2 --libdir=/usr/lib/wireshark CFLAGS="$(CFLAGS)";
+CONFIGURE_FLAGS=--prefix=/usr --sysconfdir=/usr/share --datadir=/usr/share --libdir=/usr/lib/wireshark --disable-static --enable-gtk2 --enable-warnings-as-errors=no --enable-setuid-install --with-plugins=/usr/lib/wireshark/plugins --with-lua=/usr/
configure: configure-stamp
configure-stamp: patch
@@ -35,18 +30,13 @@ configure-stamp: patch
cp /usr/share/misc/config.guess /usr/share/misc/config.sub .
libtoolize --force --copy
- autoheader
- autoconf
-mkdir aclocal-missing
- (if [ ! -x ./configure ]; then \
- ./autogen.sh $(CONFIGURE_FLAGS) CFLAGS="$(CFLAGS)"; \
- fi)
-
- ./configure $(CONFIGURE_FLAGS) CFLAGS="$(CFLAGS)"
+ ./autogen.sh
+ CFLAGS="$(CFLAGS)" ./configure $(CONFIGURE_FLAGS)
touch configure-stamp
-build: build-stamp idl2deb.1 asn2deb.1
+build: build-stamp
build-stamp: configure-stamp
$(MAKE)
@@ -63,7 +53,7 @@ clean: unpatch-stamp
rm -f build-stamp configure-stamp
[ ! -f Makefile ] || $(MAKE) distclean
- rm -f rdps wireshark.1 tshark.1 idl2deb.1 wireshark-filter.4 asn2deb.1
+ rm -f rdps wireshark.1 tshark.1 wireshark-filter.4
rm -f conftest conftest.c
rm -f config.guess config.sub config.log
rm -f config.h.in config.h configure
@@ -75,59 +65,64 @@ unpatch-stamp:
dpatch deapply-all
rm -rf patch-stamp debian/patched
-# Build architecture-independent files here.
-binary-indep: build
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build
+install: build
dh_testdir
dh_testroot
dh_clean -k
dh_installdirs
# Add here commands to install the files into debian/tmp
- $(MAKE) install DESTDIR=`pwd`/debian/tmp
- mkdir -p `pwd`/debian/tmp/usr/share/applications/
- cp wireshark.desktop `pwd`/debian/tmp/usr/share/applications/
- cp tools/idl2wrs.sh `pwd`/debian/tmp/usr/bin/
- cp debian/wireshark-root.desktop `pwd`/debian/tmp/usr/share/applications/
- mkdir -p `pwd`/debian/tmp/usr/share/pixmaps/
- cp image/hi48-app-wireshark.png `pwd`/debian/tmp/usr/share/pixmaps/
- cp image/wsicon32.xpm `pwd`/debian/tmp/usr/share/pixmaps/
- mkdir -p `pwd`/debian/tmp/usr/lib/$(PYTHON_VERSION)/site-packages/
- install -m 755 `pwd`/idl2deb `pwd`/debian/tmp/usr/bin/
- install -m 755 `pwd`/asn2deb `pwd`/debian/tmp/usr/bin/
- cp `pwd`/tools/wireshark_be.py `pwd`/tools/wireshark_gen.py \
- `pwd`/debian/tmp/usr/lib/$(PYTHON_VERSION)/site-packages/
- mkdir -p `pwd`/debian/tmp/usr/include/wireshark/
+ $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
+ mkdir -p $(CURDIR)/debian/tmp/usr/share/applications/
+ cp debian/wireshark.desktop $(CURDIR)/debian/tmp/usr/share/applications/
+ cp tools/idl2wrs.sh $(CURDIR)/debian/tmp/usr/bin/
+ #cp debian/wireshark-root.desktop $(CURDIR)/debian/tmp/usr/share/applications/
+ mkdir -p $(CURDIR)/debian/tmp/usr/share/pixmaps/
+ cp image/hi48-app-wireshark.png $(CURDIR)/debian/tmp/usr/share/pixmaps/
+ cp image/wsicon32.xpm $(CURDIR)/debian/tmp/usr/share/pixmaps/
+ mkdir -p $(CURDIR)/debian/tmp/etc/wireshark/
+ mv $(CURDIR)/debian/tmp/usr/share/wireshark/init.lua \
+ $(CURDIR)/debian/tmp/etc/wireshark/
+ ln -s /etc/wireshark/init.lua \
+ $(CURDIR)/debian/tmp/usr/share/wireshark/init.lua
+ mkdir -p $(CURDIR)/debian/tmp/usr/lib/$(PYTHON_VERSION)/site-packages/
+ cp $(CURDIR)/tools/wireshark_be.py $(CURDIR)/tools/wireshark_gen.py \
+ $(CURDIR)/debian/tmp/usr/lib/$(PYTHON_VERSION)/site-packages/
+ mkdir -p $(CURDIR)/debian/tmp/usr/include/wireshark/
for F in `cat debian/wireshark-dev.header-files`; do \
- cp --parents $$F `pwd`/debian/tmp/usr/include/wireshark; \
+ cp --parents $$F $(CURDIR)/debian/tmp/usr/include/wireshark; \
done
- # .a is no longer built; why was is used ?
- #cp `pwd`/wiretap/libwiretap.a `pwd`/debian/tmp/usr/lib/
- -rm -rf `pwd`/debian/tmp/usr/man
+ -rm -rf $(CURDIR)/debian/tmp/usr/man
dh_installman
dh_movefiles
dh_pysupport
- dh_python
dh_installdocs
- -rm debian/menu # from upstream debian/ package
dh_installmenu
dh_installchangelogs NEWS
+
+# Build architecture-independent files here.
+binary-indep: install
+# We have nothing to do by default.
+
+check: install
+ # check all necessary headers are included
+ gcc -c debian/headers-check.c `pkg-config --cflags glib-2.0` -Idebian/wireshark-dev/usr/include/ -Idebian/wireshark-dev/usr/include/wireshark/ -o /dev/null
+
+# Build architecture-dependent files here.
+binary-arch: install check
dh_strip
dh_compress
- dh_fixperms
+ dh_fixperms -Xdumpcap
dh_installdeb
- dh_shlibdeps
+ LD_LIBRARY_PATH=/usr/lib/wireshark/ dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
-source diff:
+source diff:
@echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary
+.PHONY: build clean install check binary-indep binary-arch binary