summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorMichal Labedzki <michal.labedzki@tieto.com>2015-04-08 16:09:03 +0200
committerMichal Labedzki <michal.labedzki@tieto.com>2015-04-12 16:34:46 +0000
commit56470cc80151345fbaf0551a0f7be60a228a4074 (patch)
treea3713bb39094722cc6f588cff949da893bd22cca /doc/Makefile.am
parent5b80ccb434c64f514103e114ec9f9d18d2ad86c7 (diff)
downloadwireshark-56470cc80151345fbaf0551a0f7be60a228a4074.tar.gz
Add missing androiddump stuff
Add missing androiddump stuff like: - release notes - documentation - Windows nmake support - running androiddump as a windows application instead of console on Windows - addition of androiddump to the Windows installer Change-Id: I3bc6cc70e4dc96c0cd776f3d965dd2aa0309995d Reviewed-on: https://code.wireshark.org/review/7981 Petri-Dish: Pascal Quantin <pascal.quantin@gmail.com> Petri-Dish: Michal Labedzki <michal.labedzki@tieto.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Michal Labedzki <michal.labedzki@tieto.com>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am16
1 files changed, 13 insertions, 3 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 4394a6dd31..2a0b7b11e6 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -70,7 +70,8 @@ man1_MANS = \
@dumpcap_man@ \
@rawshark_man@ \
@dftest_man@ \
- @randpkt_man@
+ @randpkt_man@ \
+ @androiddump_man@
man4_MANS = @wiresharkfilter_man@
man_MANS =
@@ -81,8 +82,8 @@ noinst_DATA = asn2deb.1 asn2deb.html idl2deb.1 idl2deb.html idl2wrs.1 idl2wrs.ht
pkgdata_DATA = AUTHORS-SHORT $(top_srcdir)/docbook/ws.css wireshark.html \
tshark.html wireshark-filter.html capinfos.html editcap.html \
- mergecap.html reordercap.html text2pcap.html dumpcap.html rawshark.html \
- dftest.html randpkt.html
+ mergecap.html reordercap.html text2pcap.html dumpcap.html androiddump.html \
+ rawshark.html dftest.html randpkt.html
#
# Build the short version of the authors file for the about dialog
@@ -204,6 +205,13 @@ dumpcap.html: dumpcap.pod ../config.h $(top_srcdir)/docbook/ws.css
--noindex \
$(srcdir)/dumpcap.pod > dumpcap.html
+androiddump.html: androiddump.pod ../config.h $(top_srcdir)/docbook/ws.css
+ $(AM_V_POD2HTML)$(POD2HTML) \
+ --title="androiddump - The Wireshark Network Analyzer $(VERSION)" \
+ --css=$(POD_CSS_URL) \
+ --noindex \
+ $(srcdir)/androiddump.pod > androiddump.html
+
rawshark.html: rawshark.pod ../config.h $(top_srcdir)/docbook/ws.css
$(AM_V_POD2HTML)$(POD2HTML) \
--title="rawshark - The Wireshark Network Analyzer $(VERSION)" \
@@ -262,6 +270,7 @@ EXTRA_DIST = \
README.wmem \
README.wslua \
README.xml-output \
+ androiddump.pod \
asn2deb.pod \
capinfos.pod \
captype.pod \
@@ -269,6 +278,7 @@ EXTRA_DIST = \
dftest.pod \
dumpcap.pod \
editcap.pod \
+ extcap.pod \
eproto2sgml \
idl2deb.pod \
idl2wrs.pod \