summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorDario Lombardo <lomato@gmail.com>2015-11-19 11:30:44 +0100
committerAnders Broman <a.broman58@gmail.com>2015-11-19 15:29:18 +0000
commitd6da95231ee790fd884ca2a41fe59aa9b05ccde9 (patch)
tree521b455286bad8276f270cb69fd4bb53192643dd /doc/Makefile.am
parent1a841483e9df85f913ece0286a6e0d4f97a859c2 (diff)
downloadwireshark-d6da95231ee790fd884ca2a41fe59aa9b05ccde9.tar.gz
extcap: add sshdump.
sshdump is an extcap module that allows dumping from a remote host using an ssh connection. It goes with the existing extcap plugin interface. Change-Id: I8987614fdd817b8173a50130812bc643a4833bca Reviewed-on: https://code.wireshark.org/review/11402 Petri-Dish: Alexis La Goutte <alexis.lagoutte@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 8f00fdfd49..1c4381ec23 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -71,7 +71,8 @@ man1_MANS = \
@rawshark_man@ \
@dftest_man@ \
@randpkt_man@ \
- @androiddump_man@
+ @androiddump_man@ \
+ @sshdump_man@
man4_MANS = @wiresharkfilter_man@
man_MANS =
@@ -83,7 +84,7 @@ noinst_DATA = asn2deb.1 asn2deb.html idl2deb.1 idl2deb.html idl2wrs.1 idl2wrs.ht
pkgdata_DATA = AUTHORS-SHORT $(top_srcdir)/docbook/ws.css wireshark.html \
tshark.html wireshark-filter.html capinfos.html editcap.html \
mergecap.html reordercap.html text2pcap.html dumpcap.html androiddump.html \
- rawshark.html dftest.html randpkt.html
+ sshdump.html rawshark.html dftest.html randpkt.html
#
# Build the short version of the authors file for the about dialog
@@ -212,6 +213,13 @@ androiddump.html: androiddump.pod ../config.h $(top_srcdir)/docbook/ws.css
--noindex \
$(srcdir)/androiddump.pod > androiddump.html
+sshdump.html: sshdump.pod ../config.h $(top_srcdir)/docbook/ws.css
+ $(AM_V_POD2HTML)$(POD2HTML) \
+ --title="sshdump - The Wireshark Network Analyzer $(VERSION)" \
+ --css=$(POD_CSS_URL) \
+ --noindex \
+ $(srcdir)/sshdump.pod > sshdump.html
+
rawshark.html: rawshark.pod ../config.h $(top_srcdir)/docbook/ws.css
$(AM_V_POD2HTML)$(POD2HTML) \
--title="rawshark - The Wireshark Network Analyzer $(VERSION)" \
@@ -293,6 +301,7 @@ EXTRA_DIST = \
rawshark.pod \
reordercap.pod \
sgml.doc.template \
+ sshdump.pod \
text2pcap.pod \
tshark.pod \
wireshark-filter.pod \