summaryrefslogtreecommitdiff
path: root/docbook/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2017-04-27 17:34:46 +0200
committerPeter Wu <peter@lekensteyn.nl>2017-04-28 10:46:30 +0000
commit122c4dd04fa762092dc5c19a522c9297ea108f04 (patch)
tree7be166cb9fb8cb4d5b9d6e4d3f59bac7c971f28d /docbook/CMakeLists.txt
parent976d8abce4194f591e18ea3da9f5673659557b9d (diff)
downloadwireshark-122c4dd04fa762092dc5c19a522c9297ea108f04.tar.gz
cmake: make docbook build optional if AsciiDoc is missing
This prevents ASCIIDOC2xxx from being invoked (which would define useless targets and error out during the build since a2x is missing). Now Wireshark.sln builds successfully without Cygwin. Change-Id: I37684ce4a2ef22bdc74b388ced44271e14a1d337 Reviewed-on: https://code.wireshark.org/review/21384 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Peter Wu <peter@lekensteyn.nl>
Diffstat (limited to 'docbook/CMakeLists.txt')
-rw-r--r--docbook/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/docbook/CMakeLists.txt b/docbook/CMakeLists.txt
index 7bdcaa8d19..121f943e40 100644
--- a/docbook/CMakeLists.txt
+++ b/docbook/CMakeLists.txt
@@ -296,6 +296,11 @@ set(WSLUA_MODULES
${CMAKE_SOURCE_DIR}/epan/wslua/wslua_struct.c
)
+if(NOT ASCIIDOC_FOUND)
+ message(WARNING "AsciiDoc not found, cannot build documentation.")
+ return()
+endif()
+
# Empty file to trigger wsluarm generation.
ADD_CUSTOM_COMMAND(
OUTPUT